0

I have installed remixd using NPM. If I run it, it gives me the following error:

Error: Cannot find module 'web3-requestManager'
    at Function.Module._resolveFilename (module.js:555:15)
    at Function.Module._load (module.js:482:25)
    at Module.require (module.js:604:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/usr/local/lib/node_modules/remixd/node_modules/web3/packages/web3-core/src/index.js:26:22)
    at Module._compile (module.js:660:30)
    at Object.Module._extensions..js (module.js:671:10)
    at Module.load (module.js:573:32)
    at tryModuleLoad (module.js:513:12)
    at Function.Module._load (module.js:505:3)

I have searched a lot of solutions for this, like installing ethereum/web3.js or using another version of the web3 package, but none works. How to fix?

  • I've fixed it by installing it locally. Make sure you run the local program. – JBrouwer Mar 15 '18 at 3:23
  • Sry, сan you explain in detail how you solved this problem? – Alex Kowalski Mar 15 '18 at 15:31
  • You can install remixd locally via npm install remixd. It will install remixd in your local node_modules directory. To see where this is, use npm root to see where it has installed. It will not link remixd to your global program (which you can call via comment line). Now find remixd in your local directory: go to your local node_modules directory and go to the .bin directory, where it stores all programs. Now in this directory call remixd and you will see it works. To finish, link this program so it runs globally and you can use it! – JBrouwer Mar 15 '18 at 15:35
  • Thx a lot! Now I get an error: bash: remixd: line 2: syntax error near unexpected token (' bash: remixd: line 2: var Router = require('./router') – Alex Kowalski Mar 15 '18 at 15:44
  • That's an error I did not get. It appears that it tries to get the Router package but it doesn't exist. Did you also try reinstalling remixd again? Maybe it somehow forgot this package? – JBrouwer Mar 15 '18 at 15:59
0

As request, here is an answer on how I fixed it.

Install remixd locally via npm install remixd. Find your local node_modules directory via npm root and move here. Now go to .bin directory inside this local node_modules directory. remixd will be here. Now call remixd in this directory and it will run. It doesn't appear to run globally, so you can fix this by linking this local program globally.

0

If you uninstall remixd npm package and install remix-ide npm package instead, which includes remixd package as well, you’ll find remixd perfectly working and complete.

Type:

npm uninstall -g remixd

npm install -g remix-ide

then you will be able to run remix both pointing your browser to http://localhost:8080 (local, offline) AND to https://remix.ethereum.org/ (remote, online).

In both cases remixd will be available.

Simply click on the chain icon in the file explorer area and you are on board. Remixd is working.

0

I tried to install remixd using npm but got several errors. However, yarn worked for me. But it I got remixd command not found. To fix this I created a node project using yarn init and added the required remixd command in my package.json.

 "scripts": {
"start": "remixd -s /home/user/directory --remix-ide https://remix.ethereum.org" }

After this, I used yarn run start. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.