Until I switched to ganache-cli from testrpc things were working fine. Now I ran testrpc and 10 accounts are displayed as shown below.Starting testrpc But I am unable to deploy any contract. it is stuck after this-enter image description here I tried re-installing testrpc but the issue persists. Please help!

  • 2
    Can you show us your truffle-config.js? Is development port configured to point to 8545?
    – Ismael
    Mar 12, 2018 at 20:27

1 Answer 1


If you have Parity running in the background you might want to kill the process.

If that does not work/apply, try running miner.start() in your web3 console. This will start the miner and your contract will be deployed on the network.

More on this issue here

  • 1
    Yes! You were right. Parity had been running in the background.Thanks Mar 16, 2018 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.