1

I followed every thing on this page :

https://medium.com/@PrateeshNanada/steps-to-install-testrpc-in-windows-10-96989a6cd594

Except step number 5 where my Node.js version is 8.10.0 instead of 8.10.2 which i dont think is a big difference.

I have installed VS 2017 Community Edition , Windows 10 SDK, OpenSSL , npm-gyp. I have ran the command npm install --global --production windows-build-tools to install all the latest build tools and still get this error. Help is needed.

EDIT

I have uninstalled Visual Studio 2017 and just install Build Tools through the npm install --global --production windows-build-tools command. A new error appears. How?

pm WARN deprecated fs-promise@2.0.3: Use mz or fs-extra^3.0 with Promise Support
npm WARN deprecated tar.gz@1.0.7: ⚠️  WARNING ⚠️ tar.gz module has been deprecated and your application is vulnerable. Please use tar module instead: https://npmjs.com/tar
npm ERR! Error while executing:
npm ERR! C:\Program Files\Git\cmd\git.EXE ls-remote -h -t git://github.com/frozeman/WebSocket-Node.git
npm ERR!
npm ERR! fatal: unable to connect to github.com:
npm ERR! github.com[0: 192.30.253.112]: errno=No such file or directory
npm ERR! github.com[1: 192.30.253.113]: errno=No such file or directory
npm ERR!
npm ERR!
npm ERR! exited with error code: 128

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Syed\AppData\Roaming\npm-cache\_logs\2018-03-12T04_26_35_361Z-debug.log
0

Node-gyp offers several alternatives to install the Visual C++ compiler, but unfortunately VS 2017 is not one of them.

From their documentation.

  • Option 1: Install Visual C++ Build Tools using the Default Install option.

  • Option 2: Install Visual Studio 2015 and select Common Tools for Visual C++ during setup. This also works with the free Community and Express for Desktop editions.

  • Option 3: if you already have Visual Studio 2015 installed and did not install the Common Tools for Visual C++ during setup, you can File -> New -> Project, pick any of the options under Templates -> Other Languages -> Visual C++ then Ok and Visual Studio will offer to install the Common Tools for Visual C++ with a "Install Missing Features" / "You need the Universal Windows App Development Tools to develop Windows app projects." dialog.

5
  • They should really update the compiler. Anyways , edited my question to address your answers. Please have a look.
    – Syed Ariff
    Mar 12 '18 at 4:32
  • @SyedAriff The error is pretty clear "fatal: unable to connect to github.com". From the status.github.com/messages it appears github.com is working I'd suggest to try again.
    – Ismael
    Mar 12 '18 at 4:40
  • Nothing changed. Tried 5 times and still the same error occurs. Tried npm install websocket but didn't change anything.
    – Syed Ariff
    Mar 12 '18 at 5:15
  • 1
    Issue solved , I voted you as the correct answer cause you managed to eliminated my previous issues. The answer is npm install ethereum/web3.js instead of npm install web3.
    – Syed Ariff
    Mar 12 '18 at 6:46
  • Interesting issue I've tried with npm install ethereum/web3.js and npm install web3 it both works without issues, Windows 7 x64, VC++ 2015 Community Edition, node v8.9.4.
    – Ismael
    Mar 12 '18 at 16:36
0

Sorry and pardon me, this is a question as I'm desperate for some help too. I've been trying all week and still getting the same errors trying load web 3@1.0.0-beta.46 on a windows 10 would any of you have any insight which may help me out please?

PS C:\Windows\system32> mkdir test28

    Directory: C:\Windows\system32


Mode                LastWriteTime         Length Name
----                -------------         ------ ----
d-----        6/14/2019   1:02 PM                test28


PS C:\Windows\system32> cd .\test28\
PS C:\Windows\system32\test28> npm install --save web3@1.0.0-beta.46

> scrypt@6.0.3 preinstall C:\Windows\system32\node_modules\scrypt
> node node-scrypt-preinstall.js


> scrypt@6.0.3 install C:\Windows\system32\node_modules\scrypt
> node-gyp rebuild


C:\Windows\system32\node_modules\scrypt>if not defined npm_config_node_gyp (node "C:\Users\HOME\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node "C:\Users\HOME\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" rebuild )
Warning: Missing input files:
C:\Windows\system32\node_modules\scrypt\build\..\scrypt\win\include\config.h
MSBUILD : error MSB1009: Project file does not exist.
Switch: build/binding.sln
gyp ERR! build error
gyp ERR! stack Error: `C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onExit (C:\Users\HOME\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\build.js:262:23)
gyp ERR! stack     at ChildProcess.emit (events.js:180:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:12)
gyp ERR! System Windows_NT 10.0.17763
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\HOME\\AppData\\Roaming\\npm\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Windows\system32\node_modules\scrypt
gyp ERR! node -v v9.10.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm WARN qunit-reporter-junit@1.1.1 requires a peer of qunitjs@* but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! scrypt@6.0.3 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the scrypt@6.0.3 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\HOME\AppData\Roaming\npm-cache\_logs\2019-06-14T00_04_06_282Z-debug.log

Thanks in advance for any advice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.