1

I've been able to get a much higher hashrate on other systems. These are the steps I've taken so far, getting ~ 17Mh/s.

Description: Ubuntu 17.10
Kernel: 4.13.0-36-generic

  1. Install amdgpu-pro-17.40-492261 (used the --compute flag. This is the only way my machine will boot)
  2. Flashed the BIOS (BIOS was found online)
    atiflash -p -f 0 Anoraks_Sapphire RX 570 Pulse 4GB Hynix Elpida_memshift-1500.rom

  3. Ran this for OC
    sudo bash -c 'echo 5 > /sys/class/drm/card1/device/pp_sclk_od'
    sudo bash -c 'echo 15 > /sys/class/drm/card1/device/pp_mclk_od'

  4. Claymore flags: -epsw x -mode 1 -ftime 10 -asm 1 -etha 0

I've also tried a kernel 'pre spectre meltdown' with no effect. Any help or advice would be much appreciated :) will send some ETH for a solution!

Update: I have noticed the SCLK & VDDC fluctuating while mining. Power goes from 95W to 105W and SCLK goes from 988Mhz to 1070Mhz...

enter image description here

Changing to Ubuntu 16.04 and Kernel 4.10 does not do anything.

  • Have changed: /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.vm_fragment_size=9 amdgpu.hw_i2c=1" – user3666672 Mar 11 '18 at 2:19
  • Have you tried running without flashing your BIOS? – hextet Mar 11 '18 at 3:01
  • Yeah, ~16Mh/s. Modding the BIOS doesn't really change much. When – user3666672 Mar 12 '18 at 3:58
0

its a krenel issue, get ubuntu 16.04.03 LTS with kernel version 4.10.0. any newer kernel and you will get up to -8 mh/s.

  • Does not make a difference. – user3666672 Mar 13 '18 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.