0

I'm using ropsten test network to deploy my contracts. Contracts are deployed successfully but when i make a transaction in truffle console it returns:

Error: unknown transaction
at Object.InvalidResponse (/usr/local/lib/node_modules/truffle/build/webpack:/~/web3/lib/web3/errors.js:38:1)
at /usr/local/lib/node_modules/truffle/build/webpack:/~/web3/lib/web3/requestmanager.js:86:1
at /usr/local/lib/node_modules/truffle/build/webpack:/~/truffle-provider/wrapper.js:134:1
at XMLHttpRequest.request.onreadystatechange (/usr/local/lib/node_modules/truffle/build/webpack:/~/web3/lib/web3/httpprovider.js:128:1)
at XMLHttpRequestEventTarget.dispatchEvent (/usr/local/lib/node_modules/truffle/build/webpack:/~/xhr2/lib/xhr2.js:64:1)
at XMLHttpRequest._setReadyState (/usr/local/lib/node_modules/truffle/build/webpack:/~/xhr2/lib/xhr2.js:354:1)
at XMLHttpRequest._onHttpResponseEnd (/usr/local/lib/node_modules/truffle/build/webpack:/~/xhr2/lib/xhr2.js:509:1)
at IncomingMessage.<anonymous> (/usr/local/lib/node_modules/truffle/build/webpack:/~/xhr2/lib/xhr2.js:469:1)
at emitNone (events.js:91:20)
at IncomingMessage.emit (events.js:186:7)

I start truffle console with: truffle console --network ropsten

and for transaction: game.createPlayer("0x35f5164d941de22942288808C1E6e406ec148336", {from: "0x35f5164d941de22942288808C1E6e406ec148336"}).then(function(res){console.log(res)})

  • Make sure you have the latest versions, check this. – Orry Vandermeulen Mar 9 '18 at 13:31
  • these are ther versions i'm using Truffle v4.0.6 (core: 4.0.6), Solidity v0.4.19 (solc-js) and geth Version: 1.8.1-stable – NoMan Ilyas Mar 9 '18 at 13:37
  • 1
    Well the fix was at Truffle 4.0.7 so you should try an update – Orry Vandermeulen Mar 9 '18 at 13:43
1

Looking at this issue you need to update to version 4.0.7 or higher to make it work.

  • upgrading truffle fixed the problem. now i'm having new issue Please check that the transaction: - satisfies all conditions set by Solidity `require` statements. - does not trigger a Solidity `revert` statement. – NoMan Ilyas Mar 9 '18 at 14:16
  • actually the contracts i'm using are not written by me so no idea about this one. i've tried with commenting the require statement in function but still it throws same error – NoMan Ilyas Mar 9 '18 at 14:17
  • You should open a new question for this new issue and mark this answer as accepted – Orry Vandermeulen Mar 9 '18 at 14:19
  • okay. done..... – NoMan Ilyas Mar 12 '18 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.