3

i am running a private Quorum node, which is basically normal ethereum node, via geth.

Then i tried to do deploy contract using migrate from truffle. but it got stuck here :

Running migration: 1_initial_migration.js
  Replacing Migrations...
  ... 0xbe63f4d73fa716a96b3e91792b24e789598978c7e93f396f0898e27dfb651c2a

this is my geth "command" : qgeth --rpc --rpcport 22000 (qgeth is justan alias for quorum geth)

and this is the output of the terminal i am running the geth on

NFO [03-05|16:55:51] Starting peer-to-peer node               instance=Geth/v1.7.2-stable-df4267a2/linux-amd64/go1.10
INFO [03-05|16:55:51] Allocated cache and file handles         database=/home/user/.ethereum/geth/chaindata cache=128 handles=1024
INFO [03-05|16:55:51] Initialised chain configuration          config="{ChainID: <nil> Homestead: 0 DAO: <nil> DAOSupport: false EIP150: <nil> EIP155: <nil> EIP158: <nil> Byzantium: <nil> IsQuorum: true Engine: unknown}"
INFO [03-05|16:55:51] Disk storage enabled for ethash caches   dir=/home/user/.ethereum/geth/ethash count=3
INFO [03-05|16:55:51] Disk storage enabled for ethash DAGs     dir=/home/user/.ethash               count=2
INFO [03-05|16:55:51] Initialising Ethereum protocol           versions="[63 62]" network=1
INFO [03-05|16:55:51] Loaded most recent local header          number=0 hash=9ff7ff…ad72b2 td=0
INFO [03-05|16:55:51] Loaded most recent local full block      number=0 hash=9ff7ff…ad72b2 td=0
INFO [03-05|16:55:51] Loaded most recent local fast block      number=0 hash=9ff7ff…ad72b2 td=0
WARN [03-05|16:55:51] Failed to journal local transaction      err="no active journal"
WARN [03-05|16:55:51] Failed to journal local transaction      err="no active journal"
INFO [03-05|16:55:51] Loaded local transaction journal         transactions=2 dropped=0
INFO [03-05|16:55:51] Regenerated local transaction journal    transactions=2 accounts=1
INFO [03-05|16:55:51] Starting P2P networking 
INFO [03-05|16:55:53] UDP listener up                          self=enode://5f7a8e81143054d8aecdfcc6a93b6d2d2a8fe0300a48a35af6dadab6cf364da9a5ea0e2dc8b75239f01a9e1cea22f6529a8308cdf447adaa2fe4e674aa3c580c@[::]:30303
INFO [03-05|16:55:53] RLPx listener up                         self=enode://5f7a8e81143054d8aecdfcc6a93b6d2d2a8fe0300a48a35af6dadab6cf364da9a5ea0e2dc8b75239f01a9e1cea22f6529a8308cdf447adaa2fe4e674aa3c580c@[::]:30303
INFO [03-05|16:55:53] IPC endpoint opened: /home/user/.ethereum/geth.ipc 
INFO [03-05|16:55:53] HTTP endpoint opened: http://127.0.0.1:22000 
INFO [03-05|17:00:01] Submitted contract creation              fullhash=0x78b4cf12fc34b32ea4d174fa2bb4d8fba5e4c018722105eb5453fc8fc0979776 to=0xA8879FfBe2f4bAea1b37D00Bb2EFF38629B94EF4
INFO [03-05|17:01:21] Submitted contract creation              fullhash=0x24f4ea4dd9f3a41bfd019381c2d630fa63a9f365615397932bf9db5c450c4c22 to=0x18EBcB24F6074147DF24C39df3b833288b0e686b
INFO [03-05|17:01:46] Submitted contract creation              fullhash=0xbe63f4d73fa716a96b3e91792b24e789598978c7e93f396f0898e27dfb651c2a to=0x7D8e4ea6319e950c5400A60ab18f305bAcAA2F12
WARN [03-05|17:06:30] System clock seems off by -72h0m7.633984816s, which can prevent network connectivity 
WARN [03-05|17:06:30] Please enable network time synchronisation in system settings. 

Why would this happen ?

1

Your node seems to have a 3 days delay with the rest of the network. Check the date of your node as a node with delay cannot communicate with the network.

Try this to enable NTP on Ubuntu: timedatectl set-ntp true

If it doesn't work, try this:

sudo apt-get update
sudo apt-get install ntp
sudo service ntp start
  • I fixed the time problem, restarted the node. Nothing happens. it is not about the time – Kaki Master Of Time Mar 8 '18 at 16:21
  • I had the same issue with Quorum.I had solved this issue by doing the same migrate command in one more terminal.btw I am still searching the reason for it – Crissi Mariam Robert Mar 8 '18 at 16:43
  • The time certainly was a problem, too. Can you post the recent geth locs after fixing the time issue ? (use pastebin or the like) – Nikita Fuchs Jul 2 '18 at 17:37
1

I had this same problem, I fixed it by updating my Ethereum node to the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.