0

I had a weird issue which was :

I have one bootnode:

bootnode -nodekey boot.key -verbosity 9 -addr :30310

Now I want to run my peers on the command line and I want them to add my bootnode as a peer to find each others, like that :

geth --datadir node1/ --syncmode 'full' --port 30311 --rpc --rpcaddr 'localhost' --rpcport 8501 --rpcapi 'personal,db,eth,net,web3,txpool,miner' --networkid 1996 --gasprice '1' -unlock '0xcf767e1258bf88520634311fc45e77f6b4cdd72a' --password node1/pass.txt --mine --bootnodes "enode://3879643f63c5257485c10f41b3604023b9de7f96267f741fbac2cb6992a4071ba45544e4055181191ef31ab7b996211a690edbc44ed64951bc4a2e7dae2199a5@127.0.0.1:30310"

This was working.

But was not working anymore when I was setting my bootnode in node1/static-nodes.json like that (as it is described in the documentation) :

[ "enode://3879643f63c5257485c10f41b3604023b9de7f96267f741fbac2cb6992a4071ba45544e4055181191ef31ab7b996211a690edbc44ed64951bc4a2e7dae2199a5@127.0.0.1:30310" ]

and using this command (which the same as above without the bootnode flag):

geth --datadir node1/ --syncmode 'full' --port 30311 --rpc --rpcaddr 'localhost' --rpcport 8501 --rpcapi 'personal,db,eth,net,web3,txpool,miner' --networkid 1996 --gasprice '1' -unlock '0xcf767e1258bf88520634311fc45e77f6b4cdd72a' --password node1/pass.txt --mine

After a lot of headache I solved my problem using sudo ntpdate -s time.nist.gov (which is also written in the documentation)

But does that mean that setting the bootnode on the file has a different action/meaning than setting it in the command line ? Why and is this an issue ?

Thanks,

Maxime

1

At least one difference between the two is that the --bootnodes argument sets explicitly the boot node addresses, whereas the static-nodes.json file sets the addresses of static full nodes (peers).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.