3

I'm new to ethereum & do not have any ethereum clients 'installed'. I'm trying to install pyethapp in a clean virtualenv following the github tutorial, but it produces the following error.

pip install pyethapp

Collecting scrypt (from pyethapp)
  Using cached scrypt-0.7.1-cp27-none-win32.whl
Collecting gipc==0.4.0 (from pyethapp)
  Using cached gipc-0.4.0.zip
Collecting werkzeug (from pyethapp)
  Using cached Werkzeug-0.11.9-py2.py3-none-any.whl
Collecting ipython>=3.0.0 (from pyethapp)
  Using cached ipython-4.2.0-py2-none-any.whl
Collecting CodernityDB (from pyethapp)
  Using cached CodernityDB-0.5.0.tar.gz
Collecting statistics (from pyethapp)
  Using cached statistics-1.0.3.5.tar.gz
Collecting pyyaml (from pyethapp)
  Using cached PyYAML-3.11.zip
Requirement already satisfied (use --upgrade to upgrade): wheel in c:\users\user01\desktop\ethereum\
venv\lib\site-packages (from pyethapp)
Collecting pexpect (from pyethapp)
  Using cached pexpect-4.1.0-py2.py3-none-any.whl
Collecting leveldb (from pyethapp)
  Using cached leveldb-0.193.tar.gz
No files/directories in c:\users\user01\appdata\local\temp\pip-build-gpzcs1\leveldb\pip-egg-info (fr
om PKG-INFO)

Do I need to install this thing called 'leveldb' manually? Or am I doing something wrong?

  • My bet is on that this is some sort of Windows related packaging issue. It says "Using cached leveldb-0.193.tar.gz". Try clear your pip cache. – Mikko Ohtamaa Feb 16 '17 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.