4

It looks like I have to sync my blockchain at least until the block when my account was funded. Because as of right now the balance for my address is still zero.

I'm runnig geth version 1.4.4-stable-8ea3c88e.

4
  • I have read that question, but besides being almost 2 months old it doesn't solve my problem. I suppose there must be a way that I can create a valid transaction since I have the private key and can probably listen to the p2p network exchange and figure out the required information. Geth is literally taking ages to sync (more than a week!). And the price of ether is as of right now extremely good to sell. I can't believe that by not keeping my ETH in an exchange, I have for all intents and purposes frozen it.
    – Bilthon
    May 23, 2016 at 5:30
  • Have you tried geth --cache=1024 --jitvm?
    – eth
    May 23, 2016 at 9:40
  • Alternatively, see ethereum.stackexchange.com/questions/3386/…
    – eth
    May 23, 2016 at 9:43

1 Answer 1

2

You could try using geth --fast that will normally take much quicker to sync your blockchain - see What is Geth's "fast" sync, and why is it faster? .

If you want to try out the fast sync, you will firstly have to clear out your old blockchain - see How to delete or reset the blockchain in geth? (OSX) . I would rename my old chaindata folder before trying out the fast sync, and if all is OK, remove my old chaindata.

While you are waiting for your syncing, you could use MyEtherWallet (https://www.myetherwallet.com/) to move your ethers.



UPDATE 1

I have just tested on Testnet and successfully executed a transaction from the Ethereum Wallet while my geth --testnet instance was 80,000+ blocks from being fully synced. The transaction showed up in https://morden.ether.camp as expected.

The only restriction with sending transactions without the Ethereum Wallet (Mist) being fully synced is that the source account in Mist must have a balance that covers the ethers you want to send, or it will prevent you from sending the transaction. This is the same behaviour as in geth as Mist sends transactions via geth.

UPDATE 2

I have also successfully executed a transaction on Mainnet when my local node was a few thousand blocks out of sync.

3
  • I actually did run geth with the --fast command line option. And it did download all the recepits, but once it got close to the latest blocks (around 1.5M), it started to download the actual blocks. Or that's what I get from this line of log: imported 28 block(s) (0 queued 0 ignored) including 21 txs in 2.574757505s. #660199 [2fe724ca / d8a1af92].
    – Bilthon
    May 23, 2016 at 6:03
  • Are you getting messages that you are losing peer connections? I sometimes get this on my non-mining node and have to restart geth again to speed up the discovery of peers. If --fast does not work for you, your best alternative is the Send Transaction page on MyEtherWallet. The line of log in your comment shows that it is at block #660199. Is this an old log line, or is this recent? If you are concerned about security, you can try the Offline Transaction page on MEW. You may want to check your router port #30303 forwarding to your geth instance as this will allow incoming p2p connections May 23, 2016 at 6:40
  • All right, MyEtherWallet seems to be more or less what I was looking for. It is a shame this functionality is not present in the geth client though. Since I'm a bit wary of using my private key with a web service like this. But I'll check their off-line transaction with an airgapped machine later on. Thanks!
    – Bilthon
    May 23, 2016 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.