3

I am testing a contract which is using ecrecover function of solidity. While its testing when i go with a failed test case while debugging, it doesn't go step by step and at the end return the same error as below. What is the reason of all this?

TypeError: Cannot read property 'start' of undefined at Debugger.step (/home/aniket/.nvm/versions/node/v8.9.3/lib/node_modules/truffle/build/cli.bundled.js:322984:59) at Object.interpreter (/home/aniket/.nvm/versions/node/v8.9.3/lib/node_modules/truffle/build/cli.bundled.js:318096:22) at ReplManager.interpret (/home/aniket/.nvm/versions/node/v8.9.3/lib/node_modules/truffle/build/cli.bundled.js:203345:18) at bound (domain.js:301:14) at REPLServer.runBound [as eval] (domain.js:314:12) at REPLServer.onLine (repl.js:442:10) at emitOne (events.js:116:13) at REPLServer.emit (events.js:211:7) at REPLServer.Interface._onLine (readline.js:282:10) at REPLServer.Interface._line (readline.js:631:8)

0

As of a little while ago, truffle debugger was not finished and throwed a lot like this. Here says that the debugger is completed now, but i haven't tried it out again yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.