2

I am trying to upload ensutils.js from https://github.com/ethereum/ens to my geth console. I am using loadScript('/home/path/to/ensutils.js').

Every time I try it, it gives me an invalid address error and I am not sure why. Would anyone happen to know what the issue is here. I have my default address set and the account unlocked.

loadScript('/home/path/to/ensutils.js')
  • Please post exactly the line how you're calling loadScript. – ivicaa Feb 22 '18 at 2:34
  • i used the same syntax for the ensutils-test.js and it uploads with out the invalid address error – Jordan Feb 22 '18 at 2:38
1

In ensutils.js, there is for example a code line like var ens = ensContract.at('0x314159265dd8dbb310642f98f50c066173c1259b');.

When your node is not synced to the mainnet, this line will fail.

| improve this answer | |
  • My console has been running for severail days, when i do eth.syncing the highest block and current block are almost the same, how do i know if it is done syncing or not? I ran that line of code in my console and it returned undefined, so i am guessing you are right – Jordan Feb 22 '18 at 3:17
  • I am also unable to unlock eth.accounts[0]. – Jordan Feb 22 '18 at 3:20
  • I tried this on a geth console of a node which is synced with the mainnet. It worked. You can copy&paste var ensContract = ... and var ens = ensContract.at... directly to the console and see what happens. – ivicaa Feb 22 '18 at 3:26
  • After running both lines, they both returned undefined – Jordan Feb 22 '18 at 3:28
  • That's ok. What happens if you type ens in the console? – ivicaa Feb 22 '18 at 3:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.