1

I'm trying to debug a failed ether transaction and to understand what went wrong.

The transaction is this one: https://etherscan.io/tx/0xaf0eb06c892cbbf75e50afec6d439f748aaed33091798b94a9dd4cc0ed253edd

I tried so far:

geth console
debug.traceTransaction('0xaf0eb06c892cbbf75e50afec6d439f748aaed33091798b94a9dd4cc0ed253edd');

Got the error: enter image description here

Maybe there is an easier way to find out what went wrong. I also tried to debug with etherscan http://etherscan.io/remix?txhash=0xbb22dde158e7f9025463127267436b8cc3f27877cfb17268fd4045e099ec5770

this looks promising but I can't see the source neither was not able to find out what went wrong.

  • I know from the remix IDE that you can step through the source code too. I was expecting to see this work at etherscan too, since the source code for the contract is attached.. Did you try the truffle debugger? -> truffleframework.com/docs/getting_started/debugging – ivicaa Feb 21 '18 at 20:10
  • I didn't try it yet, since I was not sure if it is possible to debug a past transaction and analyse what went wrong. As I understood the default setup is on test-environment. – MichaelRazum Feb 21 '18 at 20:28
  • AFAIK, you can have truffle connected to mainnet too. I didn't try it yet, but it should work. – ivicaa Feb 21 '18 at 20:29
  • OK that sounds promising. Will try it. As I understand in such a case I have to start geth and connect to it with truffle. Is this correct? Or is there an easier way. On the client side I'm using right now infura – MichaelRazum Feb 21 '18 at 20:31
  • I guess you'll have to start your own node and open the RPC port. I tried it with remix.ethereum.org + infura, but it didn't work. I think infura is not exposing all the necessary APIs. – ivicaa Feb 21 '18 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.