2

I am using geth and run a private net. In Remix I am developing and am successfully connected to the geth RPC. But when I create a contract in Remix, in the geth console it says contract created but it does not really create it or add it however. There is also no error or something but in Remix there is still "1 pending transaction". After the message in geth, geth continues mining new blocks but in some way does not include the contract creation.

My next problem is, that geth starts late. When I launch it with console and enter "miner.start(1);" it takes a long time until it really starts mining.

The problem exists only since some days, before I never had this. I also upgraded already geth to the newest version (after the problems started) but it did not fix it.

How could I fix those problems?

2

I recommend you to use ganache-cli (former testrpc) instead of geth:

  • it's easier to set up
  • it mines the blocks automatically when there's a transaction
  • you can give it some seed words and the generated accounts will always be the same
  • you can connect to it from Remix IDE
  • plenty of other developer friendly while being almost 100% compatible with geth.
  • I have Windows 7 and sadly they do not support it (yet). Do you maybe have an alternative to Ganache? – dkb Feb 15 '18 at 20:46
  • they say it's possible to install testrpc on windows – Tudor Constantin Feb 15 '18 at 20:51
  • Yes they do, but only Windows 10. – dkb Feb 15 '18 at 20:59
  • I don't see any restrictions to the windows version there. Have you actually tried to install it and it didn't work? – Tudor Constantin Feb 15 '18 at 21:03
  • Yes. I get an error of "unsupported". It does not work. Do you maybe have an alternative? – dkb Feb 15 '18 at 21:06
2

Found the solution :) I activated user account control on windows some days ago and since Geth was in a path where I had no rights to create files (it was in programs folder) geth could not update the blockchain. So I created a new privatenet in a folder where I was able to create new files (documents). Now it works. Thank you!

0

I sadly need to announce, that it does not work again. It seemed to work for first and second time but then problems started again. I have no more idea about what the reason could be. Mining works, contract creation get shown but the contract seems to not get included into any transaction (on remix it shows "pending transaction 1").. Would be great if someone maybe has an idea.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.