0

This question already has an answer here:

I tried with all available answers converting to hex and setting different gas prices, but noting is working for me. I am on a private network with network id : 1 and chainId = 0 and the nodes are in sync. geth version is 1.7.3 please help me out

marked as duplicate by Ismael, Richard Horrocks, Achala Dissanayake, Community Feb 14 '18 at 7:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    How are you sending the transactions? Mind posting some code? – Tomislav Markovski Feb 13 '18 at 17:51
  • @solmon Explain your problem in detail probly with logs – Jitendra Kumar. Balla Feb 14 '18 at 4:19
  • The setting on chainId solved my problem, i really dont understand what that means as I couldnt find any documentation of why chainId should be other than the default. – solmon Feb 14 '18 at 7:52
0

The error seems to say it all: you don't have enough ETH in the sending account.

Maybe you're actually trying to send from an account that has a balance of 0 ETH?

Not the answer you're looking for? Browse other questions tagged or ask your own question.