0

I am trying to sync my node with testnest rpc with following command. geth --testnet --syncmode "fast" --rpc --rpcapi db,eth,net,web3,personal --cache=1024 --rpcport 8545 --rpcaddr 127.0.0.1 --rpccorsdomain "*" --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@52.169.14.227:30303,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@13.84.180.240:30303"

But it is just stuck after starting a localhost server. Here is the screenshot of my terminal. enter image description here

When i try to sysnc with just geth command its syncing fine. Anyone having idea what's wrong here?

2
0

I guess 13.84.180.240, 52.169.14.227 boot nodes are down. As per eth logs its trying to dial again and again.

Add --verbosity option along with your command it will tell whats wrong/currently whats geth is doing.

geth --testnet --verbosity 6 --syncmode "fast" --rpc --rpcapi db,eth,net,web3,personal --cache=1024  --rpcport 8545 --rpcaddr 127.0.0.1 --rpccorsdomain "*" --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@52.169.14.227:30303,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@13.84.180.240:30303"

--verbosity value starts from 0 to 6.

If you want to set logs to be default then

geth attach then type debug.verbosity(3) it will reset to default.

2
  • ahhh. thanks mate. your were right, those boot nodes were down. changes the boot node and now syncing fine Feb 13 '18 at 13:27
  • @ShoaibIqbal Can you please accept my ans, It will help community to solve issues. Feb 13 '18 at 15:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.