So I just [FEB 12, 2018] spun up an Ubuntu 16.04 VM and installed geth using the ppa.

geth version

Version: 1.7.3-stable
Git Commit: 4bb3c89d44e372e6a9ab85a8be0c9345265c763a
Architecture: amd64
Protocol Versions: [63 62]
Network Id: 1
Go Version: go1.9
Operating System: linux

Now I would like to connect to testnet. My internet research claims I should be able to do

geth --testnet --syncmode "fast"


geth --testnet --rpc --rpcapi "admin,db,eth,debug,miner,net,shh,txpool,personal,web3" --syncmode "fast" --rpccorsdomain '*' --rpcaddr --rpcport 8545

Both commands result in the same...

WARN [02-12|12:13:49] No etherbase set and no accounts found as default
INFO [02-12|12:13:49] Starting peer-to-peer node instance=Geth/v1.7.3-stable-4bb3c89d/linux-amd64/go1.9
INFO [02-12|12:13:49] Allocated cache and file handles database=/home/parallels/.ethereum/testnet/geth/chaindata cache=128 handles=1024
INFO [02-12|12:13:49] Initialised chain configuration config="{ChainID: 3 Homestead: 0 DAO: DAOSupport: true EIP150: 0 EIP155: 10 EIP158: 10 Byzantium: 1700000 Engine: ethash}" INFO [02-12|12:13:49] Disk storage enabled for ethash caches dir=/home/parallels/.ethereum/testnet/geth/ethash count=3
INFO [02-12|12:13:49] Disk storage enabled for ethash DAGs dir=/home/parallels/.ethash count=2
INFO [02-12|12:13:49] Initialising Ethereum protocol versions="[63 62]" network=3
INFO [02-12|12:13:49] Loaded most recent local header number=0 hash=419410…ca4a2d td=1048576
INFO [02-12|12:13:49] Loaded most recent local full block number=0 hash=419410…ca4a2d td=1048576
INFO [02-12|12:13:49] Loaded most recent local fast block number=0 hash=419410…ca4a2d td=1048576
INFO [02-12|12:13:49] Loaded local transaction journal transactions=0 dropped=0
INFO [02-12|12:13:49] Regenerated local transaction journal transactions=0 accounts=0
INFO [02-12|12:13:49] Starting P2P networking
INFO [02-12|12:13:51] UDP listener up self=enode://399e42ef589c6202d31e64509432030b11ed642d261fa337811cb3f7838f606db47ffb91ef91dc464923450f55773f5ace698be2035a95dcaaf77f9843cf4b9b@[::]:30303
INFO [02-12|12:13:51] HTTP endpoint opened: INFO [02-12|12:13:51] RLPx listener up self=enode://399e42ef589c6202d31e64509432030b11ed642d261fa337811cb3f7838f606db47ffb91ef91dc464923450f55773f5ace698be2035a95dcaaf77f9843cf4b9b@[::]:30303
INFO [02-12|12:13:51] IPC endpoint opened: /home/parallels/.ethereum/testnet/geth.ipc

It appears to be stuck on IPC endpoint opened. I am both a linux newbie and an ethereum newbie. Just trying to learn. I don't know where to start looking for what is wrong. Can you help me get this going?

Update: After an hour and a half there's a new message

INFO [02-12|13:44:02] Regenerated local transaction journal transactions=0 accounts=0

2 Answers 2


Turns out this was a networking question.
I had to port forward TCP and UDP ports 30303 on the router to my VM's IP address.

After doing that and restarting geth, the chain began to synchronize almost immediately.

  • I've tryied geth for couple weeks. It simply doesnt work as expected. It synced for the first time with fast param. And the, after couple days began to lag from chain again. I tried everyhning. The only way it worked was to remove db and start syncing over. Each time it was hanging on sync noumerous times. Finally i switched to parity - had no troubles with syncing at all. And it has same rpc interfaces, so dont waste your tie on geth. Commented Feb 13, 2018 at 0:13

Thank you very much was also having the same issue when I tried to run geth for the first time on my system. I applied what is suggested above, i.e. port forward TCP and UDP ports 30303 on the router. I am using a Huawei B525 router and did the following: settings->security->special applications-> special applications list

Name: geth; status: on; trigger port: 30303; trigger protocol:TCP; open protocol: UDP; open port 30303; then click add, ok, apply.

Then went cmd prompt run geth and it did run past IPC endpoint open!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.