1

I'm running Parity 1.9.2 - sync'd quick, in about 15 hours. Now I'm trying to use it with my Ledger Nano to sign some dApps (MakerDAI). I've installed the Parity extension for Chrome, it's showing green (connected to Mainnet).

I connect my Ledger and Parity recognizes it. It's showing up in the Accounts page - it's also showing as connected.

I'm just trying to enable some of the permissions shown on the DAI Dashboard page. I click a slider, which prompts Parity to open a signer window in the bottom right corner of the screen. It's asking me to give permission to sign the transaction. I change the gas price to what I want it to be, then click on the acknowledge button... at this point my Nano should show me the transaction and ask me to approve it - this never happens.

I click the acknowledge button multiple times in the signer window but nothing ever happens on my Nano.

Did this break somewhere along the way? This has worked for me in the past on a previous version of Parity.

Is this a known issue? Any suggestions?

Thanks.

1

Instructions: https://github.com/paritytech/parity/wiki/Ledger-Nano-S

Once you plugged-in your Ledger Nano S to your computer, it will usually auto-detect your account and make it available in your Parity Wallet if you mind the following steps:

  • Make sure you have the latest Nano S firmware installed on your device (>= 1.3.1).
  • Make sure you have the latest Ethereum application installed on your device (>= 1.0.8).
  • Plug-in your Nano S to your computer.
  • Unlock your device.
  • Enter the Ethereum application on the Nano S.
  • Make sure the Browser Mode is deactivated in your Ethereum settings on the device.

Have you verified these steps, especially the last one?

  • Hi - yes, I already did all of that. I have the latest firmware / ethereum app. Browser mode is deactivated. The Nano shows as being connected in the Parity UI - this would not be the case if I was in Browser Mode. – RBizzle Feb 9 '18 at 13:29
  • 1
    Might be same as this issue: github.com/paritytech/parity/issues/… – RBizzle Feb 10 '18 at 1:03
0

Did u figure it out? i had the same issue after i just reinstalled 1.8.1 and followed the instructions above with no luck then i went to the applications in parity and clicked permissions on the top right and clicked my wallet and now the dai dashbord sees my ledger

  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – flygoing Mar 1 '18 at 19:18
  • @flygoing It is somehow an answer, it adds "clicked permissions on the top right" – Ismael Mar 2 '18 at 5:16
  • @ismael it isn't answering the question. all they gave was what they also did to get the same results, e.g. a "I'm having this issue too" post, which is fine for comments but not for answers – flygoing Mar 2 '18 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.