While trying to connect Ganache-cli to remix, I get this error,

Not possible to connect to the Web3 provider. Make sure the provider is running and a connection is open (via IPC or RPC).

But remix IDE is able to connect to testRPC and not Ganache-cli, i have both on my system, I tried with both local copy of remix as well with online remix IDE.

  • 2
    Doesn't work on Brave browser. However it works with Crome browser for both http & https versions of remix.
    – Despotovic
    Commented May 13, 2021 at 14:15

2 Answers 2


Run Remix from http://remix.ethereum.org, not https

Found the answer here: Testrpc running on 8545, yet Remix can't connect

  • 's answer worked for me. If you are using brave browser then please disable the shield protection and change the https to http in the address bar
    – hariAnitha
    Commented Feb 13, 2022 at 19:07

This is most likely due to an add blocker. I did not have to do any of the http changes described in the other answers. I was using Brave Browser and just had to disable the Brave Shields ("Shields Up") and was good to go.

Not the answer you're looking for? Browse other questions tagged or ask your own question.