9

I set second owner for contract with ETH and dailly limit for transfers. I can transfer ETH under this limit. But large quantity transfer (to DAO contract) is not work. One owner (my first account in the wallet) click Send transaction and... nothing.

"After a few minutes at most, a “confirmation pending” transaction should be at the top" Alexandre Van de Sande wrote on www.ethereum.org. But it's not any button appear for second owner confirmation in Mist. I think I must execute some contract function, mabe "Confirm"? But "h" parameter is not clear for me. I tried to write first transaction hash to this field, I tried some other functions like "remove owner"... but not successfully.

Maybe the problem is both owners in one wallet? My ETH is freezing becuase of this experiment with second owner :) And I don't know what to do.

  • 1
    Are you talking about mist or are you invoking a custom contract from the command line? Could you add some more details on what you are doing and experiencing? – Waqar Lim May 13 '16 at 7:46
  • Have the same issue with a second signature on GUI Ethereum wallet. Nothing happens on a second user wallet (a second owner of the wallet). I also can't revoke transaction that stuck on my multi-user wallet. Any ideas how to fix this and release funds? – user49992 May 17 '16 at 23:12
  • Ok, everything worked after we imported multi-user wallet to another computer. – user49992 May 18 '16 at 1:25
  • If you've managed to get this working, please add an answer detailing what you did, and mark it as accepted :) – Richard Horrocks Feb 21 '17 at 14:38
2

Without the code, it sounds like you have a multi-sig wallet contract that requires 2 actions to spend over the daily limit. It sounds like you performed the first action and were expecting some sort of interactive prompt to perform the second. No client that I'm aware of has the smarts to recognize that situation and prompt for the confirming method call.

"...imported multi-user wallet to another computer..." sounds like you added the contract ABI to a client on another computer - presumably one with the account of the second owner address on it.

That it worked means you've triggered that confirmation with the second action - whatever it might be.

(Please post code next time so readers don't have to guess!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.