I'm using truffle with ganache GUI. It worked fine at first, but now I am unable to start it. (I made it executable)

When I run ./ganache.AppImage I get this message:

installed: X-AppImage-BuildId=b74a6d80-fbda-11a7-0d5d-97de34ed8487 image: X-AppImage-BuildId=b74a6d80-fbda-11a7-0d5d-97de34ed8487

then nothing happens.

PS: i can start ganache-cli with no problem

  • You may want to create your own custom node. Truffle breaks a lot because it still in rapid development. – Daniel Mar 1 '18 at 4:02

I had similar issue. By any chance, did the last time you opened it you played with Host or Port Number in the settings? I input a Port number in the Host field, and it wouldn't restart. Had to go in the ganache GUI folder and basically erase the whole folder (Basically uninstall reinstall if you can). Reading issues from ganache repo, it seemed like a bug they have yet addressed. Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.