1

I'm trying to run the following command:

geth --datadir mychaindata --nodiscover --unlock 0 --mine 1

and getting the above error.

When I enter geth account list, I see two accounts.

What gives?

2
  • 1
    What the output of geth --datadir mychaindata account list? Jan 31, 2018 at 13:37
  • WARN [01-31|15:57:35] No etherbase set and no accounts found as default
    – Boris K
    Jan 31, 2018 at 13:57

1 Answer 1

1

The option --datadir declare where are your data would be placed, the whole data includes keystores, database and so on. When you're invoking the command geth account list it's uses the default datadir (~/.ethereum). Looks like that directory doesn't contains any accounts. In order to force address you can use the --etherbase option:

geth --datadir mychaindata --nodiscover --unlock 0 --mine --etherbase YOUR_ADDRESS_GOES_HERE

Command-Line-Options

4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.