Mist (0.7.2) freezes on Linux Ubuntu 15.10

Mist (0.7.2) freezes and just displays a white rectangular box especially when I stop it and restart it. This is white screen before the Mist browser even launches. Initially I could see the downloading blockchain splash screen so it might not be related to a video or graphics issue. Not sure.

Even if I kill the processes and restart Mist it remains frozen.

If I log out of Ubuntu and back in the problem remains.

The only thing that seems to fix it is restarting the computer.

Any advice?

  • Generally useful to include version/s of Mist that was tried.
    – eth
    May 10, 2016 at 10:09
  • Updated the question. Mist 0.7.2. You think downgrading to an earlier version would solve the issue? Any version in particular being stable?
    – Vesa
    May 10, 2016 at 12:42
  • @eth I tried closing all Ethereum processes, downloading 0.6.2 and clicked it. It seems to run and just take off where 0.7.2 ended. ethereum.stackexchange.com is so useful and cool : ) Well, I will see how it goes. Will report if I get stuck somewhere again.
    – Vesa
    May 10, 2016 at 12:50
  • This question will probably be closed as a duplicate soon. If the answers from the duplicates don't fully address your question please edit it to include why and flag this for re-opening. Thanks!
    – q9f
    May 10, 2016 at 14:35
  • I rejoiced too early. First it worked with Mist 0.6.2 but then it started to behave oddly again. What's up with these freezing issues when downloading the blockchain initially?
    – Vesa
    May 11, 2016 at 4:23


Browse other questions tagged or ask your own question.