6

I tried to build EthereumH from this github resource: https://github.com/jamshidh/ethereumH

I installed google's git-repo and tried to install at as described in the README. It failes with the following missing repository (404):

remote: Repository not found.
fatal: Authentication failed for 'https://github.com/kjameslubin/hserver-eth/'

I then tried to skip the umbrella repository, and tried to install the ethereum-client-haskel with cabal: https://github.com/jamshidh/ethereum-client-haskell

But that's a mess, too:

 $ cabal install ethereum-client-haskell
Resolving dependencies...
cabal: Could not resolve dependencies:
trying: ethereum-client-haskell-0.0.4 (user goal)
trying: base-4.8.2.0/installed-0d6... (dependency of ethereum-client-haskell-0.0.4)
trying: cmdargs-0.10.14 (dependency of ethereum-client-haskell-0.0.4)
trying: process-1.2.3.0/installed-78f... (dependency of cmdargs-0.10.14)
next goal: haskoin (dependency of ethereum-client-haskell-0.0.4)
rejecting: haskoin-0.1.0.2, 0.1.0.1, 0.1.0 (conflict: process => deepseq==1.4.1.1/installed-614..., haskoin => deepseq>=1.3 && <1.4)
rejecting: haskoin-0.0.2.1, 0.0.2 (conflict: base==4.8.2.0/installed-0d6..., haskoin => base>=4.6 && <4.7)
Dependency tree exhaustively searched.

I also figured out that this project might be integrated in Consensys / Blockapps, but only found an empty repository: https://github.com/blockapps/ethereumH

Is this project still alive? How to build or install the haskell client EthereumH on a Linux system?

2

I see you've created an issue in the appropriate repo, and received no reply, so the project is likely not alive.

hserver-eth seems to have a few more repositories on github: kejace with last commit on Jun 15, 2015; and a fork of that by Firescar96, with about a hundred more commits up to Jul 31, 2015 (the latest commit, in 2016, only added an AGPLv3 LICENSE file).

Seems to be the same project, may be worth getting in touch with these two people if you're still interested. However, I'd assume that it hasn't been used on the "mainnet(s)" much.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.