0

I'm starting to learn the in and outs of dapp development. I followed a few tutorials -I can now read solidity!. I want to try modifying some existing dapps to get a sense of what's going on, in particular in multiplayer games.

I found the "on-chain-chess" dapp https://github.com/ise-ethereum/on-chain-chess and I'm trying to start from here as a training example (ie by coding checkers and/or fantasy chess from there).

However I'm running into trouble when trying to use the dapp. I launched testrpc and npm installed/npm started it. I have a couple warnings during building phase.

When opening index.html, nothing happens when I click on "create game". I have no reaction on the testrpc and no reaction on the browser. I'm probably missing something that I can't figure. I thought that this has to do with mining time, but it does not seem to be the answer.

Is there something obvious? Is there a good tutorial explaining this kind of problematics? Or should I try with another project?

0

When you open the console, do you see any error messages? I was able to get it up and running, I used npm install, followed by npm start. When you run npm start, you should see a lot of movement on testrpc because the contracts are deploying, did you see that? Also, you'll want to access it via http://localhost:8080/. There are some simpler tutorials with Truffle as well, if that helps.

  • Hi, thank you for your answer. I have two warnings when running npm install (peer dependencies from mocha. I tried modifying package.json but it went worse) When running npm start I indeed see a lot of output on the testrpc terminal. I go to localhost:8080/webpack-dev-server/index.html which indicates "app ready", but clicking on "start a new game" or "join game" has no effect, neither on my browser nor on testrpc console. I tried going to localhost:8080 and get the same results, albeit the URL changes when I click (/#/initializeGame, /#/joinGame), the screen stays black. – Alternative Jan 26 '18 at 20:59
  • When you open up the page, can you use F12 to see the console log on the page? Usually, you will see some errors if web3 connection isn't working, which is what the case sounds like. Also, do you use Metamask? Because you would need to make sure that Metamask is set to testrpc if that's the case. – Karen S Jan 26 '18 at 21:10
  • You are right, I indeed have an error in the console log: Error: The MetaMask Web3 object does not support synchronous methods like eth_call without a callback parameter. I tried to clone the repo again and try on chrome and firefox but the same error stays. Metamask is set to localhost:8545 which is where the testrpc should be running. The innermost function triggering the error is in angular.js and the line reads return instanceInjector.invoke(provider.$get, provider, undefined, serviceName). – Alternative Jan 27 '18 at 9:29
  • I finally managed to display the website and get reactions by deactivating metamask. I am not sure why it wouldn't function with metamask... Now I am getting an out of gas error when I want to create a game, no matter the gas limit I set when launching testrpc... But I'm glad to see progress. – Alternative Jan 28 '18 at 1:17
  • Hmm, have you made sure to use the 12 word password for testrpc when using Metamask? The out of gas error would pertain to how much gas you are sending as an account user. So, it might pertain to the way their UI was done as well, if you are not able to adjust your gas using Metamask. I highly suggest the Truffle Dapps though. I think they are much easier to get going and can show you some simpler designs to start out with. Also, I've heard good things about CryptoZombies (cryptozombies.io) as well. – Karen S Jan 29 '18 at 1:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.