0

This question already has an answer here:

So I've had huge problem to get the Ethereum network to sync. I've tried several times, even on different computers. Trying to remove the old DB and run "geth --fast cache=1024". Anyhow, my current sync has stopped a few hundred blocks from the finish line and it just keeps downloading chain structure.

I'd like to deploy a contract and I don't think I can use https://remix.ethereum.org/ since I need to use the Open Zeppelin Framework. Is it possible to deploy contracts without the network being synced?

marked as duplicate by Ismael, Achala Dissanayake, Richard Horrocks, flygoing, debris Jan 23 '18 at 9:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

You don't need to sync with testnet to test your contracts, you can create and use your own private chain.

There are some ways to do it:

  • use geth. There is a very convinient tool called puppeth for setting your own private chain. puppeth is distributed in Geth & tools.
  • another way (which IMO is easier) is to become aquainted with Truffle and TestRPC.
1

Assuming you want to connect to the mainnet, not testnets, have you tried using light client mode? Much easier to connect to the mainnet this way, and it does allow you to deploy contracts.

geth --syncmode light console

Not the answer you're looking for? Browse other questions tagged or ask your own question.