1

This question already has an answer here:

A few months ago, I had no problem to synchronize my Debian node.

Now, I lag behind and I cannot catch up. There are long delays between blocks Here, a gap of several hours:

I0507 03:40:13.321969   16722 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 1378 txs in 45.488001366s. #1338740 [52e1c2f7 / 3d439d7a]
I0507 03:42:08.166768   16722 blockchain.go:1251] imported 120 block(s) (0 queued 0 ignored) including 2242 txs in 1m54.838952559s. #1338860 [74d6bc48 / 571a00ed]
I0507 07:03:40.398729   16722 blockchain.go:1251] imported 1 block(s) (0 queued 0 ignored) including 5 txs in 1.689365821s. #1338861 [3c7c01e5 / 3c7c01e5]
I0507 07:03:44.060437   16722 blockchain.go:1251] imported 4 block(s) (0 queued 0 ignored) including 16 txs in 2.390481608s. #1338865 [927ea50a / adffd667]

Restarting geth helps for a while, then it lags again. Here, in ten minutes, it handled only 1792 blocks:

 I0507 10:42:34.436031   14563 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 717 txs in 1m31.364560511s. #1339483 [23503255 / 62f7a23e]
I0507 10:45:20.742741   14563 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 1586 txs in 2m46.304754148s. #1339739 [8d414a9e / e03acc8d]
I0507 10:48:32.431543   14563 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 1775 txs in 3m11.686776776s. #1339995 [03107cee / bd02756b]
I0507 10:49:55.772369   14563 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 1006 txs in 1m23.296969827s. #1340251 [12803cd1 / 2db0e35c]
I0507 10:51:03.415782   14563 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 984 txs in 1m7.641494118s. #1340507 [c012afb1 / 3fbdfcc5]
I0507 10:52:05.977043   14563 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 1125 txs in 1m2.545164795s. #1340763 [102cda33 / 61ddeea2]
I0507 10:53:02.005868   14563 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 979 txs in 56.026910217s. #1341019 [f99249f3 / 80edeedc]

It would be enough if there were not these long stops. What can I check on my machine/network?

geth -fast does not help. May be because of this message at startup:

I0508 13:29:49.476026   30960 handler.go:92] blockchain not empty, fast sync disabled

Geth/v1.3.6/linux/go1.5.1

[Added later]

To be sure it was not the fault of the machine/network, I bought a dedicated server, 4cores and so on, and a proper Internet connection, which I monitor with Icinga to be sure there is no glitch. The problem goes on. For instance, the machine did nothing in the last hours. It is now 0902 and the last block was 12 hours before:

I0510 20:29:57.981100   30192 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 229 txs in 6.654488036s. #263709 [df5a5d05 / 2cf0a4a3]
I0510 20:30:01.578214   30192 blockchain.go:1251] imported 122 block(s) (0 queued 0 ignored) including 97 txs in 3.594111842s. #263831 [62820dc4 / 8c183313]
> 

On the same machine, testnet is synchronized in a few hours, without these stops.

marked as duplicate by soc1c May 7 '16 at 10:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Either slow hardware (disk i/o, cpu) to process the blocks or bad internet connection. See this and that. – soc1c May 7 '16 at 10:37
  • If it were a network problem, I would have the message "Synchronisation failed: no peers to keep download active", no? – bortzmeyer May 8 '16 at 11:35
  • This is still a duplicate. The answer to geth --fast doesn't not work is because you must delete the chaindata folder and then use geth --fast. This will ensure you have a blockchain with no errors and will sync fully, quickly. – tayvano May 8 '16 at 20:30