6

I am having problems getting Mist to sync, so would like to run geth --fast. I can not find the folder to run geth from? Do I need to install it separately, I thought it was bundled with Mist? I am new to terminal so some basic instructions would be appreciated. Any help would be appreciated. I am running OS X 10.11.4 and Ethereum-Wallet-macosx-0-7-2.

  • I've followed every set of instructions I can find and it still takes forever. geth --fast doesn't speed it up at all. – Sailor Soane Jun 3 '17 at 20:11
  • What times did you get with and without the --fast flag? Were they both a similar order of magnitude? – Richard Horrocks Jun 3 '17 at 20:19
  • tried following these instructions but doesn't seem to work anymore. Has something been updated or am I missing something? (I am not a programmer just trying to get a working ehter wallet as it is no pretty much mathematically impossible to catch up with the blockchain) – user18879 Sep 9 '17 at 20:59
6

Install geth - Mac

https://github.com/ethereum/go-ethereum/wiki/Installation-Instructions-for-Mac

  1. Open Terminal.

  2. Install homebrew by pasting this line and hitting enter : /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

  3. Install geth by running each of these in terminal one at a time (copy, paste, hit enter, wait)

brew tap ethereum/ethereum

brew install ethereum

Run geth fast

  1. Open Terminal and type geth --fast and hit enter

Delete chaindata

If you have already started syncing Mist you may want to delete your chaindata. I would recommend doing this as it ensures you get the full benefits of --fast, and allows you to start fresh. For those re-syncing after months, it'll help eliminate corrupted chain files, ensure no problems from before homestead - > after homestead, and help get rid of bloat.

  1. Open Mist and go Accounts - > backup - > accounts.

  2. If you have any accounts, copy the files inside keystore (they look like UTC-2016-5-16.......) to your Desktop AND a USB drive (or two). These are your encrypted private keys. If you lose these, any ETH inside these accounts will be inaccessible and lost forever.

  3. Go up a folder level and find the chaindata folder. Delete just this chaindata folder. Alternatively, you could move it to your Desktop if you think the sync might not work and you want to recover it later.

  4. Then run geth --fast

UPDATE: geth --fast has been deprecated. Use geth syncmode="light" insted.

  • Great thanks for your detailed answer much appreciated :) The chain finally synced by itself through Mist earlier today, so I am now up and running. I tried installing Geth as you suggested and got a software version not compatible error. But all good anyway now I am up to date. Thanks again. – Sabretooth May 7 '16 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.