2

We have 4 Computers with LXC containers installed. We have 4 geth instances running on host PCs and 4 geth instances running on LXC containers. My issue is that the nodes on host PCs and LXC containers are not able to connect each other and form peer connections.

This is the output of ifconfig on one of the PC and the IP of container is 10.0.3.84:

enter image description here

Initially, all the geth instances were running on port 30303 and we tried admin.addPeer(enode://XXXX@<ip-of-container>:30303) on host node to connect. But failed.

Then we ran host geth instances and Container geth instances on different ports. But still we were unable to make a connection.

Then we enabled port forwarding on the host PC using iptables -t nat -A PREROUTING -p udp -i eth0 --dport 587 -j DNAT --to-destination 10.0.3.84:587

and then ran the nodes on different ports (host node on port 30303 and container node on port 587). Then on the host node we tried admin.addPeer(enode://XXXX@<ip-of-the-host>:587) but it failed again.

I will be obliged to any solution provided.

  • What if it's just the two that I use my iOS phone 8plus and.my Moto g 5 – WALTER ALLEN BOLES Jan 17 '18 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.