3

I'm trying to run this command from this post, however when I run:

$ geth --exec "eth.getTransaction('0xbb8ee9866ee67277986b6f40775469c7a674810ce99dce3caff0d1117c8dcdac').input" console

it gives me the error:

error: TypeError: Cannot access member 'input' of null

Here is full log:

$ geth --exec "eth.getTransaction('0xbb8ee9866ee67277986b6f40775469c7a674810ce99dce3caff0d1117c8dcdac').input" console
I0505 18:56:53.049949   26203 flags.go:425] WARNING: No etherbase set and no accounts found as default
I0505 18:56:53.050144   26203 database.go:71] Alloted 16MB cache to ~/Library/Ethereum/chaindata
I0505 18:56:53.060683   26203 database.go:71] Alloted 16MB cache to ~/Library/Ethereum/dapp
I0505 18:56:53.067958   26203 backend.go:314] Protocol Versions: [63 62 61], Network Id: 1
I0505 18:56:53.068571   26203 backend.go:362] Blockchain DB Version: 3
I0505 18:56:53.069163   26203 blockchain.go:214] Last header: #0 [d4e56740…] TD=17179869184
I0505 18:56:53.069181   26203 blockchain.go:215] Last block: #0 [d4e56740…] TD=17179869184
I0505 18:56:53.069187   26203 blockchain.go:216] Fast block: #0 [d4e56740…] TD=17179869184
I0505 18:56:53.075383   26203 cmd.go:115] Starting Geth/v1.3.6-9e323d65/darwin/go1.6
I0505 18:56:53.075487   26203 server.go:311] Starting Server
I0505 18:56:55.162538   26203 udp.go:212] Listening, enode://bfcb192b0d374ff7c5186a6ee96aa38cd71d8f87afa1e1fa153d42ff0d15ea93f67f035d984af921d21305cb0cd94ee3b71bfab60fc2c4bf5578620d488e4fa0@[::]:30303
I0505 18:56:55.162758   26203 backend.go:526] Server started
I0505 18:56:55.162787   26203 server.go:552] Listening on [::]:30303
I0505 18:56:55.163135   26203 ipc.go:112] IPC service started (~/Library/Ethereum/geth.ipc)
error: TypeError: Cannot access member 'input' of null
I0506 00:54:47.997968   54842 blockchain.go:690] Chain manager stopped
I0506 00:54:47.997994   54842 handler.go:192] Stopping ethereum protocol handler...
I0506 00:54:47.998007   54842 handler.go:202] Ethereum protocol handler stopped
I0506 00:54:47.998015   54842 tx_pool.go:156] Transaction pool stopped
I0506 00:54:47.998023   54842 backend.go:630] Automatic pregeneration of ethash DAG OFF (ethash dir: ~/.ethash)
I0506 00:54:47.998163   54842 database.go:158] closed db: ~/Library/Ethereum/chaindata
I0506 00:54:47.998488   54842 database.go:158] closed db: ~/Library/Ethereum/dapp

And when getting the transaction directly in geth console (as suggested), it's printing null, e.g.

> eth.getTransaction('0x6aae61d3b11e84caf573bb71ae44b9099db8dde996fb29c8b3aa6872681aa87d')
null

My geth is v1.3.6.

How to solve this issue?

2

The reason why your transaction is not listing is because there are some strange hidden characters in the text you copied and pasted.

The following statement works:

eth.getTransaction('0xbb8ee9866ee67277986b6f40775469c7a674810ce99dce3caff0d1117c8dcdac')

The following statement does not work:

eth.getTransaction('0xbb8ee9866ee67277986b6f40775469c7a674810ce99dce3caff0d1117‌​c8dcdac')

I copied both statements into a text file and used vi to view the contents and the strange characters then show up:

enter image description here

  • @kenorb, could you try running geth console, then eth.getTransaction('0xbb8ee9866ee67277986b6f40775469c7a674810ce99dce3caff0d1117c8dcdac'). What do you see? – The Officious BokkyPooBah May 6 '16 at 0:00
  • You may have found something strange. If you replace your quote characters, it might just work. Try this statement: $ geth --exec 'eth.getTransaction("0xbb8ee9866ee67277986b6f40775469c7a674810ce99dce3caff0d1117c8dcdac")' console – The Officious BokkyPooBah May 6 '16 at 0:04
  • Executing eth.getTransaction('0x6aae61d3b11e84caf573bb71ae44b9099db8dde996fb29c8b3aa6872681aa87d') gives null even after block synchronisation started. – kenorb May 6 '16 at 0:10
  • Both with single and double-quote when ran multiple times gives null (every time). When synchronisation is started, it's quiet difficult to see what I'm executing, because the text about importing blocks is all over the screen. – kenorb May 6 '16 at 0:18
  • Solved the issue. There are some hidden characters in your original text. See the screenshot. – The Officious BokkyPooBah May 6 '16 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.