I need your help, please. I've been trying to deploy a simple token and crowdsale contract that creates the token on remix, but when I try to deploy the crowdsale contract, it tells me gas exceeds the current block limit. I've tried increasing the gas limit severally, but it's still telling me the same thing. Please what can I do?

  • Are you using the Javascript VM as the environment? – Harry Wright Jan 15 '18 at 13:31
  • Harry Wright, no I'm not. I'm using injected web with metamask – sissy Jan 15 '18 at 13:33
  • What test net are you using? What gas price are you using? – Harry Wright Jan 15 '18 at 14:47
  • Harry Wright, im using ropsten, and gas limit is 3000000. I even set it as high as 90000000 when trying to deploy, but it's not working. Still says gas required exceeds limit. – sissy Jan 15 '18 at 14:52
  • What is that gas price though, they are different things. Maybe you are setting that gas limit too high. You also need to make sure you have the ether to pay for the transaction in your account. – Harry Wright Jan 15 '18 at 14:55

I've noticed when deploying within truffle or remix that if my contracts don't adhere to their interfaces, they will compile but won't deploy, and will complain about the gas limit. Check that any contracts that implement an interface implement it correctly.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.