0

I am creating a private blockchain network for testing by doing all the initial steps like creating genesis block and data folder etc.

Here are some initial commands I have used

geth --datadir "./data" init genesis.json

after running this command I Got following output

WARN [01-15|17:37:00] No etherbase set and no accounts found as default
INFO [01-15|17:37:00] Allocated cache and file handles         database="E:\\my node\\data\\geth\\chaindata" cache=16 ha
ndles=16
INFO [01-15|17:37:00] Writing custom genesis block
INFO [01-15|17:37:00] Successfully wrote genesis state         database=chaindata                            hash=629461
.8c5a75
INFO [01-15|17:37:00] Allocated cache and file handles         database="E:\\my node\\data\\geth\\lightchaindata" cache=
16 handles=16
INFO [01-15|17:37:00] Writing custom genesis block
INFO [01-15|17:37:00] Successfully wrote genesis state         database=lightchaindata                            hash=6
29461.8c5a75 

After that I executed following command

geth --networkid 1020 --datadir "./data" --nodiscover --port 30307 --rpc 8105 --rpcaddr 10.37.1.75 --rpccorsdomain "*" --rpcapi "eth,net,web3" console

and got following output

WARN [01-15|17:37:47] No etherbase set and no accounts found as default
INFO [01-15|17:37:47] Starting peer-to-peer node               instance=Geth/v1.6.7-stable-ab5646c5/windows-amd64/go1.8.
3
INFO [01-15|17:37:47] Allocated cache and file handles         database="E:\\my node\\data\\geth\\chaindata" cache=128 h
andles=1024
WARN [01-15|17:37:47] Upgrading chain database to use sequential keys
INFO [01-15|17:37:47] Initialised chain configuration          config="{ChainID: 1020 Homestead: <nil> DAO: <nil> DAOSup
port: false EIP150: <nil> EIP155: <nil> EIP158: <nil> Metropolis: <nil> Engine: unknown}"
INFO [01-15|17:37:47] Database conversion successful
INFO [01-15|17:37:47] Disk storage enabled for ethash caches   dir="E:\\my node\\data\\geth\\ethash" count=3
INFO [01-15|17:37:47] Disk storage enabled for ethash DAGs     dir=C:\\Users\\User(LPT-APR2015-02)\\AppData\\Ethash coun
t=2
WARN [01-15|17:37:47] Upgrading db log bloom bins
INFO [01-15|17:37:47] Bloom-bin upgrade completed              elapsed=4.000ms
INFO [01-15|17:37:47] Initialising Ethereum protocol           versions="[63 62]" network=1020
INFO [01-15|17:37:47] Loaded most recent local header          number=0 hash=629461.8c5a75 td=1024
INFO [01-15|17:37:47] Loaded most recent local full block      number=0 hash=629461.8c5a75 td=1024
INFO [01-15|17:37:47] Loaded most recent local fast block      number=0 hash=629461.8c5a75 td=1024
INFO [01-15|17:37:47] Starting P2P networking
INFO [01-15|17:37:47] RLPx listener up                         self="enode://900958e9480389b0abf1b41152f174fdbe6221fd9f7
8c72f1cfc4bf4c092933fced964356b20314faa3fdc4258fcd7eddcf30d8a68fb589d67ab6b0ab7d81258@[::]:30307?discport=0"
INFO [01-15|17:37:47] IPC endpoint opened: \\.\pipe\geth.ipc
INFO [01-15|17:37:47] HTTP endpoint opened: http://127.0.0.1:8545

Now the issue is I have specified IP addess as 10.37.1.75 and port as 8105 then why the end point is opened at 127.0.0.1:8545

Note:I have done it several times before this at that time the endpoint was started at 10.37.1.75:8105

0

You want to use "--rpc --rpcaddr 10.37.1.75 --rpcport 8105" parameters.

| improve this answer | |
-1

When you start geth, you have to specify the IP and port,

| improve this answer | |
  • yes I have done that, see the second command in the question – SwapnilKumbhar Jan 15 '18 at 13:29
  • If you are on Windows, you would have to use double quotes around IP. I have noticed that if any parameter is not in right format, remaining parameters are disregarded and set to defaults – Chim Jan 15 '18 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.