4

EtherScan.io is showing error: The ERC-20 Token Transfer might have Failed (ErrCode: unable to locate corresponding Transfer event log), check with sender.

Transactions are successful but users are not receiving tokens. Can someone help to explain what error is hiding?

Out of gas error? But not all provided gas was used.

Transaction example: https://etherscan.io/tx/0x20081e3012905d97961c2f1a18e1f3fe39f72a46b24e078df2fe446051366dca

  • same thing happened to me with shapeshift.io and i am still waiting a reply. just pisses me off. I use it quite often, but i don't think i will again, it is nerve wracking. – abdulrahman abulkhair Jan 13 '18 at 2:08
  • Me neither. I tried to send my token several times but I could not. – Iwao Jan 13 '18 at 9:07
  • I have tried to send my tokens twice as well and get the same error message. Anyone knows why it happens, and how to correct it? I made sure of lots of gas money. – Drlivingstonewashere Jan 13 '18 at 14:36
1

So this is how I debug these sorts of problems:

  • Click the contract address you sent to

  • Find a transaction WITHOUT a red/orange (!) symbol

  • Compare it to your failed one

  • Repeat for another one

Sometimes it's the gas limit—it wants a higher gas limit like 200000. Sometimes there is no difference. If you can't tell, your best bet is to reach out to the token creators and ask them. They hopefully have more specific troubleshooting tips for you.

protected by Community Jan 14 '18 at 14:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.