1

I'm trying to set a PoA private Blockchain. I have a problem with the gas limit : Actually, as there's not enough transactions, the gas limit is decreasing continuously . Is there any way I can set in the genesis file a minimal limit the gas shouldn't go below?

Thank's in advance for your help.

1 Answer 1

1

In the genesis file there is a gasLimit field that is used to set the intial gas level but like you're seeing this will move up or down with every block. These values are only applicable to the genesis block.

But you should be able to use the --targetgaslimit flag to set a value that the gas limit will move towards.

2
  • 1
    Thks for the reply, I will test it. If I set the same value in the genesis gasLimit field and in each sealer/miner using --targetgaslimit, does it mean that the gas limit will stay always the same? at this value? even if there's no transaction for a while?
    – mhaddad
    Commented Jan 10, 2018 at 14:13
  • 1
    You should only need to set that --targetgaslimit once. I'm unsure, I'd need to test it, but that is what I would expect.
    – Nevin
    Commented Jan 10, 2018 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.