I'm trying to run geth on a new mac and it gets stuck when trying to sync. I'm running geth --testnet --syncmode "fast"

This is the console output:

INFO [01-06|11:33:20] Starting peer-to-peer node
instance=Geth/v1.7.3-stable/darwin-amd64/go1.9.2 INFO [01-06|11:33:20] Allocated cache and file handles
database=/Users/pabloruiz55/Library/Ethereum/testnet/geth/chaindata cache=128 handles=1024 INFO [01-06|11:33:20] Writing custom genesis block INFO [01-06|11:33:20] Initialised chain configuration
config="{ChainID: 3 Homestead: 0 DAO: DAOSupport: true EIP150: 0 EIP155: 10 EIP158: 10 Byzantium: 1700000 Engine: ethash}" INFO [01-06|11:33:20] Disk storage enabled for ethash caches
dir=/Users/pabloruiz55/Library/Ethereum/testnet/geth/ethash count=3 INFO [01-06|11:33:20] Disk storage enabled for ethash DAGs
dir=/Users/pabloruiz55/.ethash count=2 INFO [01-06|11:33:20] Initialising Ethereum protocol
versions="[63 62]" network=3 INFO [01-06|11:33:20] Loaded most recent local header number=0 hash=419410…ca4a2d td=1048576 INFO [01-06|11:33:20] Loaded most recent local full block number=0 hash=419410…ca4a2d td=1048576 INFO [01-06|11:33:20] Loaded most recent local fast block number=0 hash=419410…ca4a2d td=1048576 INFO [01-06|11:33:20] Regenerated local transaction journal
transactions=0 accounts=0 INFO [01-06|11:33:20] Starting P2P networking INFO [01-06|11:33:23] UDP listener up
self=enode://cff9f6def208edea618095eeec2b2f96532188e248775447c14bcf092eb73f97ed27411f56b1737d3caf0815b677c1b47cc72dbb8c0ab7ef4d2f0192c56a23e6@ INFO [01-06|11:33:23] RLPx listener up
self=enode://cff9f6def208edea618095eeec2b2f96532188e248775447c14bcf092eb73f97ed27411f56b1737d3caf0815b677c1b47cc72dbb8c0ab7ef4d2f0192c56a23e6@ INFO [01-06|11:33:23] IPC endpoint opened: /Users/pabloruiz55/Library/Ethereum/testnet/geth.ipc

It always gets stuck after that last message. Tried using --syncmode "light" or just geth --testnet, but it's the same.

Syncing mainnet DOES work. Syncing Rinkeby DOES work.

Any ideas?

  • What the output of eth.syncing? Also try to setup larger cache, you've setuped cache=128. Jan 6, 2018 at 15:47
  • Few weeks ago I had similar issues in syncing. Then moved to Parity. Works like a charm.
    – Chim
    Jan 6, 2018 at 17:13
  • 1
    eth.syncing = false and current block = 0, I'll try increasing the cache. Jan 6, 2018 at 17:16
  • 1
    Since yesterday I've tried to sync with different internet connections and it always show "dial tcp connectex: No connection could be made because the target machine actively refused it." when launching geth with --verbosity 6
    – Ismael
    Jan 9, 2018 at 16:38
  • 1
    Haven't tried again. I ultimately gave up and went to sync on Rinkeby. Jan 9, 2018 at 17:54

3 Answers 3


I found this node: enode://94c15d1b9e2fe7ce56e458b9a3b672ef11894ddedd0c6f247e0f1d3487f52b66208fb4aeb8179fce6e3a749ea93ed147c37976d67af557508d199d9594c35f09@ on this page:


and it seemed to fix my issue.

bash$ geth --testnet --syncmode "fast" --rpc --rpcapi db,eth,net,web3,personal --cache=1024  --rpcport 8545 --rpcaddr --rpccorsdomain "*" --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@,enode://94c15d1b9e2fe7ce56e458b9a3b672ef11894ddedd0c6f247e0f1d3487f52b66208fb4aeb8179fce6e3a749ea93ed147c37976d67af557508d199d9594c35f09@" --verbosity=6
  • 1
    Wow I have been fighting with this one, thanks for posting this, it worked for me
    – standup75
    Feb 2, 2018 at 23:32

Try to run

geth --testnet --syncmode "fast" --cache=1024 console

and then in console:


Ropsten Troubleshooting

  • 1
    Sorry, but this didn't work. Same behavior. Jan 9, 2018 at 17:54
  • Does not work for me either. Jan 11, 2018 at 13:30

I have synced geth 1.8.15 to Ropsten, after adding some resources. I am using an ec2 t3 medium; two cores, 4 g ram, and 150 g ssd. Before bumping the processor, I was running out of memory on a t2 micro with a 30 g drive. Bumping the host solved the memory problem, but the drive thrashed. I'm hoping the 150 g drive will accommodate the live net. I start geth with geth --testnet, plus arguments to start the rpc server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.