0

This question already has an answer here:

I tried really hard to figure this out on my own, but I'm pretty out of my depth, and I feel like the things that I have found that could answer my questions assume I already know some stuff. I'm fairly new to crypto, but I kept hearing everyone say to get your stuff off of the exchanges and into a wallet. I got the wallet from the ethereum website, opened it up, saw an address, and sent my ETH there. I can link the transaction if that's helpful. I have been unable to sync since then. I can get within 100ish blocks, but then it just stops. I'm well past the block containing my transaction, but my wallet still reads as empty. I see now that I'm supposed to have command line tools or something. I don't know nearly as much about computers as my mom thinks I do, and I'm wondering what I can do to access my ETH. Can anyone help me?

marked as duplicate by Ismael, Richard Horrocks, flygoing, Roman Frolov, Thomas Clowes Jan 4 '18 at 16:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • In the default configuration of EthereumWallet you will not see a valid balances until it has completed syncing. You can check your balance in a block explorer like etherscan.io. – Ismael Jan 3 '18 at 3:17
0

To see your current balance you're going to need to fully sync your wallet.

If your're having issues syncing check you're using the latest wallet and try deleting your chaindata and trying to sync again.

If you're still not seeing the transaction after a full sync it might me worth checking you sent the ether to the right address!

  • How can I delete my chain data and start my sync again? And do I have to back up my key data first? I read that somewhere, but don't know how. I really have no idea what I'm doing here. Thanks for your help! – Ben Honken Jan 3 '18 at 10:28
  • Yeah back-up your keydata to be safe, you don't want to lose that. Depeneds on your system but assuming you're using Mist the chain data will be something like Ethereum/geth/chaindata try deleting the contents of that folder and reopening your wallet. – Nevin Jan 3 '18 at 12:42
  • Alright, I've tried deleting it a few times now, but it seems like any time my computer does anything else, the sync gets interrupted and it behaves in the same way, getting closer and closer to fully syncing, but never actually getting there. I'll just keep deleting it and starting over. I definitely have the right address. I've double checked it like 9 times. – Ben Honken Jan 4 '18 at 15:40
  • How long have you tried leaving it to sync it might take a significant time to actually carry out the sync. It might also be worth backing up your keystore and trying to reinstall the software. Also as mentioned by @Ismael, in the meanwhile of trying to sync your wallet it might be worth trying something like etherscan.io to check if your transaction has been carried out. – Nevin Jan 5 '18 at 18:43
  • I've left it overnight and it gets to a certain point and then just freezes. I know it's not downloading the same block for 5 hours. I just close it and open it again and it does some more. The first time I run it after clearing I can usually get about 1-1.5 million blocks, but each time after that is less and less. I'm currently at 4.2 million blocks and getting about 20,000 every time I restart it. I'll try reinstalling if I get all the way to the end and it does the same thing. I did check etherscan, and it did go through. – Ben Honken Jan 6 '18 at 19:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.