I have a problem with my node. I have set up a remote node which was working for a few months but recently the synchronisation has stuck. So I deleted the db to resync and this is where my problems started. The VPS I am using is running Debian 9 btw. I cannot get my node to sync whatever I do. Either the node syncs without warp and gets stuck between block 2.4M and 2.6M or when warp works it syncs up to block 4.5M but the remaining 300k blocks get synced with a speed of 2 blocks per second. Today after a fresh reinstallation of the server I tried syncing the light client which got stuck at block 3,099,999. Steps to reproduce what I am doing:

apt-get install gcc g++ libssl-dev openssl libudev-dev pkg-config git make curl
curl https://sh.rustup.rs -sSf | sh
git clone https://github.com/paritytech/parity
cd parity
cargo build --release

also I wanted to try to build a stable version of parity but it didn't work as well. I always end up with the unstable version. I tried:

git checkout tags/v1.7.11
git checkout stable

but no success. how do I install a stable version of parity and how can I fix my syncing issues

2 Answers 2


You want to:

  1. Delete Existing Chain data parity --light db kill
  2. Start light sync parity --light(would recommend this if you don't need Debug traces)

A relevant post on how to do so is Here.


The stuck issue, most likely is this ongoing issue. If so, will need to wait for Parity to get it fixed.

To checkout v1.7.11, do

git checkout v1.7.11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.