1

I've created my private network run my Geth Node as:

geth --datadir /mychaindata --rpc --rpccorsdomain "*" --nodiscover

I can successfully attach it and create account when I run:

geth attach ipc:/mychaindata/geth.ipc

I've written a smart contract and I want to deploy it via Mist. I've downloaded Mist source code and switched to master branch, and compiled the source code. When I run this:

yarn dev:electron --rpc /mychaindata/geth.ipc

It successfully starts with an error at command line:

yarn run v1.3.2
$ electron -r babel-register main.js --rpc /mychaindata/geth.ipc
[2018-01-01T16:19:26.381] [INFO] Settings - Running in production mode: false
[2018-01-01T16:19:26.416] [INFO] EthereumNode - undefined null 'fast'
[2018-01-01T16:19:26.417] [INFO] EthereumNode - Defaults loaded: geth main fast
[2018-01-01T16:19:26.548] [INFO] main - Starting in Mist mode
[2018-01-01T16:19:26.672] [INFO] Db - Loading db: /Users/kamaci/Library/Application Support/Electron/mist.lokidb
[2018-01-01T16:19:26.679] [INFO] Windows - Creating commonly-used windows
[2018-01-01T16:19:26.680] [INFO] Windows - Create secondary window: loading, owner: notset
2018-01-01 16:19:26.703 Electron[93067:4305016] *** WARNING: Textured window <AtomNSWindow: 0x7ffbe3d9e170> is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.
[2018-01-01T16:19:26.864] [INFO] updateChecker - Check for update...
[2018-01-01T16:19:29.413] [INFO] Windows - Create primary window: main, owner: notset
[2018-01-01T16:19:29.422] [INFO] Windows - Create primary window: splash, owner: notset
[2018-01-01T16:19:29.485] [ERROR] main - Couldn't infer if computer automatically syncs time. Error: checkEnabled is not supported on this operating system
    at Object.checkEnabled (/Users/kamaci/projects/mist/node_modules/os-timesync/index.js:97:30)
    at checkTimeSync (/Users/kamaci/projects/mist/main.js:218:18)
    at /Users/kamaci/projects/mist/main.js:170:5
    at Generator.next (<anonymous>)
    at step (/Users/kamaci/projects/mist/main.js:140:191)
    at /Users/kamaci/projects/mist/main.js:140:361
    at <anonymous>
[2018-01-01T16:19:29.893] [INFO] ClientBinaryManager - Initializing...
[2018-01-01T16:19:29.894] [INFO] ClientBinaryManager - Checking for new client binaries config from: https://raw.githubusercontent.com/ethereum/mist/master/clientBinaries.json
[2018-01-01T16:19:31.247] [INFO] ClientBinaryManager - Initializing...
[2018-01-01T16:19:31.247] [INFO] ClientBinaryManager - Resolving platform...
[2018-01-01T16:19:31.247] [INFO] ClientBinaryManager - Calculating possible clients...
[2018-01-01T16:19:31.248] [INFO] ClientBinaryManager - 1 possible clients.
[2018-01-01T16:19:31.248] [INFO] ClientBinaryManager - Verifying status of all 1 possible clients...
[2018-01-01T16:19:31.249] [INFO] ClientBinaryManager - Verify Geth status ...
[2018-01-01T16:19:31.269] [INFO] ClientBinaryManager - Checking for Geth sanity check ...
[2018-01-01T16:19:31.269] [INFO] ClientBinaryManager - Checking for Geth sanity check ...
[2018-01-01T16:19:31.270] [INFO] ClientBinaryManager - Checking sanity for Geth ...
[2018-01-01T16:19:31.274] [INFO] ClientBinaryManager - Checking sanity for Geth ...
[2018-01-01T16:19:31.396] [ERROR] ClientBinaryManager - Sanity check failed for Geth Error: Unable to find "1.7.2" in Geth output
    at Promise.resolve.then.then.then (/Users/kamaci/projects/mist/node_modules/ethereum-client-binaries/src/index.js:635:17)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:109:7)
[2018-01-01T16:19:31.400] [INFO] Sockets/node-ipc - Connect to {"path":"/Users/kamaci/eth/as1/mychaindata/geth.ipc"}
[2018-01-01T16:19:31.402] [INFO] Sockets/node-ipc - Connected!
[2018-01-01T16:19:31.403] [INFO] NodeSync - Ethereum node connected, re-start sync
[2018-01-01T16:19:31.404] [INFO] NodeSync - Starting sync loop
[2018-01-01T16:19:31.405] [INFO] Sockets/4 - Connect to {"path":"/mychaindata/geth.ipc"}
[2018-01-01T16:19:31.405] [INFO] Sockets/2 - Connect to {"path":"/mychaindata/geth.ipc"}
[2018-01-01T16:19:31.406] [INFO] main - Connected via IPC to node.
[2018-01-01T16:19:31.427] [INFO] Sockets/4 - Connected!
[2018-01-01T16:19:31.427] [INFO] Sockets/2 - Connected!
[2018-01-01T16:19:32.086] [INFO] updateChecker - App is up-to-date.

Mist window is a white window:

Window Window

How can Mist connect to my private geth node?

  • i Stuck with same problem .do you find any solution ? – Umar Abbas May 15 '18 at 15:54
0

Starting geth with below command worked for me

geth --datadir=./chaindata/ --rpc --ipcpath ~/Library/Ethereum/geth.ipc console

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.