0

I just reinstalled parity and I'm getting an error now. In my config.toml file when I add

cors = "null"

I get following error

Loading config file from /root/.local/share/io.parity.ethereum/config.toml
You might have supplied invalid parameters in config file.
invalid type: string "null", expected a sequence for key `rpc.cors`

the weird thing is it worked previously and now it doesn't

6
  • What version of parity do you use ? Commented Dec 30, 2017 at 18:49
  • version Parity/v1.9.0-unstable-51e6e0b4b-20171230/x86_64-linux-gnu/rustc1.22.1 Commented Dec 30, 2017 at 22:34
  • You should try a stable version. I recommend 1.7.11 . The property cors = "null" is working fine on my node. Commented Dec 30, 2017 at 22:52
  • how do I install a stable version when building from source? Commented Dec 30, 2017 at 22:53
  • Pull the tag v1.7.11 rather than the master branch. git checkout tags/v1.7.11 Commented Dec 30, 2017 at 22:56

1 Answer 1

0

Try to include following option when launching parity.

--jsonrpc-cors null

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.