0

I encounter my first serious issue with the populus tutorial when I try to execute the following command:

populus chain new horton

The output is:

Mac:tutorial admin$ populus chain new horton
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/3.6/bin/populus", line 11, in <module>
    load_entry_point('populus==2.2.0', 'console_scripts', 'populus')()
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/click/core.py", line 722, in __call__
return self.main(*args, **kwargs)
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/click/core.py", line 697, in main
rv = self.invoke(ctx)
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/click/core.py", line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/click/core.py", line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/click/core.py", line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/click/core.py", line 535, in invoke
return callback(*args, **kwargs)
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/click/decorators.py", line 17, in new_func
return f(get_current_context(), *args, **kwargs)
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/populus/cli/chain_cmd.py", line 38, in chain_new
new_local_chain(project.project_dir, chain_name)
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/populus/api/utils.py", line 79, in new_local_chain
account = create_new_account(data_dir, password, **geth_kwargs)
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/geth/accounts.py", line 116, in create_new_account
stderrdata,
ValueError: Error trying to create a new account
Command    : nice -n 20 geth --rpc --rpcaddr 127.0.0.1 --rpcport 8545 --rpcapi admin,debug,eth,miner,net,personal,shh,txpool,web3,ws --ws --wsaddr 127.0.0.1 --wsport 8546 --wsapi admin,debug,eth,miner,net,personal,shh,txpool,web3,ws --datadir /Users/admin/Documents/league_fiesta/ethereum/tutorial/chains/horton/chain_data --maxpeers 0 --networkid 1234 --port 30303 --ipcpath /Users/admin/Documents/league_fiesta/ethereum/tutorial/chains/horton/chain_data/geth.ipc --verbosity 5 --unlock 0 --password /Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/geth/default_blockchain_password --nodiscover --mine --minerthreads 1 account new
Return Code: 127
stdout: N/A
stderr:
`b'nice: geth: No such file or directory\n'`

I can't figure out how to solve this issue.

Thanks for your help!

  • It looks like maybe you don't have geth installed? – smarx Dec 23 '17 at 2:22
0

populous expects geth to be installed and in your $PATH. Installing geth through something like homebrew should solve your issue.

  • You're right! I thought geth was already installed. – gael Dec 23 '17 at 11:14
  • Glad it's fixed - hit that answer button too :) – Nick Dec 23 '17 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.