0

In my contracts I've been placing pragma solidity ^0.4.2; Without knowing my compiler is outdated at 0.4.16! Interestingly, all contracts still compile and are able to migrate to testrpc. Still, I would like to make sure, is it possible this could introduce unseen errors in the future? enter image description here

1

Actually, 0.4.2 is older than 0.4.16. Versions follow consecutive numbering within smaller releases. The latest as of now is 0.4.19.

| improve this answer | |
  • Ok wow! Then V 0.4.2 significantly predates 0.4.16 then.. Back to my question, any possible ill effects from incorrect compiler declaration? – jamarcus_13 Dec 22 '17 at 6:11
  • Yes, you are using a compiler version that doesn’t have the features and security improvements that have been made during the past year. You should try to use the latest stable version. Changes made to new versions don’t affect what has already been deployed as those will compile to the specified compiler version. – pabloruiz55 Dec 22 '17 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.