6

Trying to setup solo mining using Geth, but every time I try to start mining I get:

X Failed to submit hashrate.
X Dynamic exception type: class jsonprc::JsonRpcException
std::exception::what: Exception -32003 : Client connector error: libcurl error:
7 -> Could not connect to http://127.0.0.1:8545

My blockchain is synchronized. What else could it be?

6

I'm assuming that you are using geth to run your Ethereum node, and ethminer to run the mining calculations. And you are running both from the same computer. If this is the case, here are some of the configuration parameters you will need to use:

geth will need to have the --rpc command line option:

geth --rpc --rpcaddr "127.0.0.1" --rpcport "8545" [your additional options]

It is mainly the --rpc option that you need above, as the --rpcaddr and --rpcport options are the default.

In ethminer, you will need the following configuration parameters:

ethminer -F http://127.0.0.1:8545 [your additional options]

protected by Community Jan 31 '18 at 12:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.