0

This question already has an answer here:

When I try web3.fromWei(eth.getBalance("<My Account>"), "ether") I get 0. Also when I install and run the Ethereum Wallet, I see my account but it says 0. But when I open etherchain and input my address I see

Balance: 0.05455706564854493 Ether ($27.74) | Buy more

I tried

eth.sendTransaction({from:eth.accounts[1], to:'<other address>', value: web3.toWei(0.05, "ether"), gas:21000});

and I get Error: insufficient funds for gas * price + value

Where as the Mist application just sits and spins syncing and downloading blocks. If I choose "Launch App" then I see my wallet but the balance is 0,

What am I doing wrong?

READ BEFORE YOU SHRUG THIS OFF IF YOU SEARCHED!

Actually I wasn't doing anything wrong it just doesn't work like that.

I needed to import my UTC into Metamask and it worked perfect, I waited around for 4 days and tried to sync thanks to you guys saying it was a duplicate.

:-(

marked as duplicate by Ismael, lungj, Richard Horrocks, Malone, flygoing Dec 12 '17 at 15:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    You need to wait for Mist to finish syncing. Then you'll see your balance update to the right value. – I.B Dec 12 '17 at 2:22
  • That is taking FOREVER, and what is the excuse for Web3? – Jackie Dec 12 '17 at 2:50
  • Did you connect web3 to a running Ethereum node? – I.B Dec 12 '17 at 2:53
  • To be sure it is not a duplicate, how did you sync? – Distic Dec 12 '17 at 15:11
  • I did connect to a geth instance using geth --rpc console then putting the send through. I am synching though mist, so far two days and 10% :-( – Jackie Dec 13 '17 at 5:10