2

I wanted to make my first transaction between my wallets (geth to ledger), so I put my ledger into USB and enter the pin. Geth was able to see my ledger (eth.accounts[1]), and I tried just a small amount of money to see, if it works. (I removed some sensitive information, because I don't know if my problem is now in a state, where somebody can get my "lost" money)

> eth.sendTransaction({from:eth.coinbase, to:eth.accounts[1], value: web3.toWei(<small_amount>, "ether")})
"0xblalbla"

Everything went fine. So I made a larger transaction:

> eth.sendTransaction({from:eth.coinbase, to:eth.accounts[1], value: web3.toWei(<larger_amount>, "ether")})
"0xblalbla2"

But then I realised, that the eth.accounts[1] did not get any value (somehow lost the ledger, but wasn't in sleep mode, it was still in Ethereum app).

> web3.fromWei(eth.getBalance(eth.accounts[1]));
Error: invalid address
    at web3.js:3930:15
    at web3.js:5025:28
    at map (<native code>)
    at web3.js:5024:12
    at web3.js:5050:18
    at web3.js:5075:23
    at <anonymous>:1:14

I disconnected, and connected again. Tried to make a new transaction. (now I know I should have been cancel my actual Pending transaction)

> eth.sendTransaction({from:eth.coinbase, to:eth.accounts[1], value: web3.toWei(<larger_amount>, "ether")})
"0xblalbla3"

Now I have seen, that there are already 2 pending Transactions

> eth.pendingTransactions [{
    blockHash: null,
    blockNumber: null,
    from: <geth_account>,
    gas: 90000,
    gasPrice: 50000000000,
    hash: "0xblalbla2",
    input: "0x",
    nonce: 1,
    r: "xx",
    s: "xx",
    to: null,
    transactionIndex: 0,
    v: "0x25",
    value: <larger_amount> },
{
    blockHash: null,
    blockNumber: null,
    from: <geth_account>,
    gas: 90000,
    gasPrice: 52000000000,
    hash: "0xblalbla3",
    input: "0x",
    nonce: 2,
    r: "xx",
    s: "xx",
    to: <ledger_account>,
    transactionIndex: 0,
    v: "0x26",
    value: <larger_amount> }]

So I looked for a solution on the internet, and tried to get rid of the Pending transactions.

> eth.sendTransaction({from:eth.coinbase, to:eth.accounts[1], value: 0, gasPrice: 57720000000, gasLimit: 24000, nonce: 2});
"0xblabla4"

I successfully removed the nonce 2, but in the meantime the nonce 1 became success. It was sent to null, and that created a contract.

How can I get the money back to my wallet address, if there is a way? If there is no sensitive information, then I can put all the information here, if it is needed to recover my eth.

Thank you in advance!

1

You have deployed an empty contract which was asigned the ether you sent. Immediately there's nothing you can do to recover your funds from that empty contract.

Although there is a proposal EIP 156 to recover ether frozen from certain type of contracts. One of them being empty contracts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.