0

enter image description here

I am trying to make private block chain. I am following this link

5
  • Hi there. What command did you use to start Geth? If it's a brand new private chain, there shouldn't be any data to sync. Dec 5, 2017 at 17:11
  • @RichardHorrocks thanks for replying. I ran "geth — identity “yourIdentity” — init /path_to_folder/CustomGenesis.json — datadir /path_to_your_data_directory/ACPrivateChain" this command Dec 5, 2017 at 17:14
  • Just to check - did you substitute values into each of the parameters? i.e. Did you substitute something for "yourIdentity"? There's a part in the link you referenced about network IDs - have you tried doing that? Dec 5, 2017 at 17:35
  • @RichardHorrocks I have substitute values but still it was syncing, now i am trying commands written below on that same post (the network ID command). Please suggest me any good link to proceed with setting up private ethereum block chain Dec 5, 2017 at 18:16
  • Have a look at this previous question and answers for some other ideas: ethereum.stackexchange.com/questions/125/… (Some of the answers are quite old, but the general idea should be the same.) Dec 5, 2017 at 18:21

1 Answer 1

0

If it is importing all the headers that means its syncing with public block chain.

So to make private blockchain. Please follow below steps

  1. create genesis.json
  2. run on mac terminal - "geth init path_to_geneis/genesis.json"
  3. then to start your private network run - "geth -networkid=111 console" [111: choose any unique number for network id]
  4. your console for private network will get open. now you can proceed !!

Thanks in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.