1

This summer (2017) I got interested in Ethereum. I started learning about it and decided to make a wallet using Geth. I vaguely remember that the first wallet I created had something wrong with it or I hadn't figured out the Geth CLI that well.. I don't remember exactly what were the issues / what I did to solve them, nor do I know if this is even relevant to the issue.

A couple of days ago I tried to send a transaction from my Ethereum Wallet and was prompted for my password. I did not specifically remember which password I used, but I am fairly certain it is one of my regularly used passwords.
I tried every single one of my regularly used passwords, without success. Then I remembered that I had to make the password in the CLI interface, where you can't actually see what you are typing. So maybe I had CAPSLock enabled, or maybe NumLock was off? I tried everything I could possibly think of, without success. I started looking online if anyone else was having password issues as this is the first time that I've ever had any problems with a password.

As of writing I've tried a number of things which I will shortly list:
1. Tried importing my wallet into MyEtherWallet.com with my password
2. Tried all passwords I could come up with within the GUI when you want to send a Transaction
3. Tried all the passwords I could come up with within the CLI using geth account update myAddress
4. Wrote a script in Python based off of pyethrecover_v3 (https://github.com/danielchalef/pyethrecoverv3/blob/master/pyethrecover_v3.py) and generated 10,000 passwords with a typo that I am checking against the UTC file right now

I highly doubt that I would write the same typo TWICE while making the account
(you have to repeat the password while creating your account in the Geth CLI).

Now for the part which baffles me the most. My UTC file is of the format: UTC--2017--06--04T.... which would mean that the UTC was created on the 4th of June. But in Windows Explorer the UTC file says that it was lastly modified on the 19th of June 2017. I'm not sure if this has to do with the first paragraph of this post or if Geth did something to the UTC file..
Are there any cases known where someone's UTC file got in some way re-encrypted with a different password or something?

I have to say at this point I'm extremely desperate and any help/information would be immensely appreciated!

Kind regards,
Mr. Stressed-out

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.