2

I am running geth node on a pretty robust server with lots of disk space, memory and processor (screenshot attached). Once geth fully syncs and I connect mist wallet to it it shows the latest blocks and number of peers all that. Next time I try to connect it shows at 6000-8000 blocks behind and need to wait and dont get the latest txs. Right now, it would never catch up with the latest blocks. There is not error/warning in geth console. How can I keep geth syching upto date? Its running 247365 I remember it happened with way early version of geth too almost a year ago..so definitely its not related to this particular version. I also tried with running geth in light mode it helps catching up fast but then falls behind again ! enter image description here enter image description here

  • 1
    Try increasing the cache of geth to at least 4GB (option --cache 4096) – gisdev_p Nov 25 '17 at 20:52
  • You made a fatal mistake, you are using Windows. Install linux and configure HugeTLB. You would get 5x speed on every application just by doing that. There are also other performance tuning options, but you have to dive into it if you want to squeeze everything out of your hardware – Nulik Nov 25 '17 at 22:12
  • i am not sure its entirely on windows tho.While definitely something could be done in configuration , here is what I am running it as of now: – kahmed Nov 27 '17 at 17:37
  • geth.exe --rpc --rpcport 40003 --datadir "E:\Ethereum" --keystore "E:\Ethereum\keystore" --ethash.dagdir "E:\Ethereum\geth\ethash.dagdir" --ipcdisable – kahmed Nov 27 '17 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.