1

After installing go under $HOME/bin/go, I'm doing these commands:

cd go-ethereum
my path now includes /home/pi/bin/go/bin
make geth

I also tried sudo make geth and got the same error. Oddly enough, sudo didn't ask me for my password like on other linux machines I work on. At the make command I get these errors:

pi@rpi3b-cr:~/bin/go-ethereum $ make geth
build/env.sh go run build/ci.go install ./cmd/geth
internal/build/azure.go:23:2: cannot find package "github.com/Azure/azure-storage-go" in any of:
/home/pi/bin/go/src/github.com/Azure/azure-storage-go (from $GOROOT)
/home/pi/bin/go-ethereum/build/_workspace/src/github.com/Azure/azure-storage-go (from $GOPATH)
internal/build/pgp.go:27:2: cannot find package "golang.org/x/crypto/openpgp" in any of:
/home/pi/bin/go/src/golang.org/x/crypto/openpgp (from $GOROOT)
/home/pi/bin/go-ethereum/build/_workspace/src/golang.org/x/crypto/openpgp (from $GOPATH)
Makefile:15: recipe for target 'geth' failed
make: *** [geth] Error 1

I also tried:

  • sudo apt-get install eth and sudo apt-get install ethereum and neither could be found in the package repo. The error was "unable to locate package geth" or similar.

How do I install geth? Or even Parity? I have not been able to find instructions that work yet.

Thank you! I'm a noob when it comes to installing a node, and to Rpi, although I know a little linux.

  • 2
    Hi there. Noting those instructions are nearly 2 years old, you might have more luck with a newer set: pinode.co.uk or pgaleone.eu/raspberry/ethereum/archlinux/2017/09/06/…. (Unsure what your issue actually is - others might know more.) – Richard Horrocks Nov 25 '17 at 14:10
  • Thanks. @RichardHorrocks. I ordered a UPS and powered USB hub just for my RPi. My 1TB seagate USB drive seems to be drawing too much power and my video blinks off an on every few minutes, which I assume is a low power problem. (Video monitor is a VGA adapter but goes through an adapter to make it HDMI to connect it to the RPi.) – Bulrush Nov 26 '17 at 18:57
2

I was in the exact same situation and solved this by installing the geth binary directly.

  1. Find the latest arm7 geth binary here

  2. The link address is harder to track down, but it's https://gethstore.blob.core.windows.net/builds/geth-linux-amd64-1.7.3-4bb3c89d.tar.gz

  3. $ wget https://gethstore.blob.core.windows.net/builds/geth-linux-amd64-1.7.3-4bb3c89d.tar.gz

  4. untar it with $ tar -xvf geth-linux-amd64-1.7.3-4bb3c89d.tar.gz

  5. then cd geth-linux-amd64-1.7.3-4bb3c89d

  6. move the binary into your /bin with sudo mv geth /usr/local/bin/

  7. Then make sure you've got it working with $ geth license or $ geth h

Credit to https://owocki.com/install-ethereum-geth-raspberry-pi-b/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.