0

I have an issue to setup ip address for node I run on my machine.

The command is

docker run -it -p 8545:8545 -p 30303:30303 -v /home/user/Workspace/myether/datadir1:/root/datadir user/my-ether-node /bin/bash

I expect to see ip address, but id doesn't have it.

veth2c0a981 Link encap:Ethernet  HWaddr 6e:41:c9:a5:83:ac  
          inet6 addr: fe80::6c41:c9ff:fea5:83ac/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:586 (586.0 B)  TX bytes:6320 (6.3 KB)

I will need on the second stage when I have to publish enode

I have connection to the network.

Any advice?

0

In docker command, you have to specify the RPC option to expose your IP to the outer world to connect

--rpc --rpcaddr "0.0.0.0" --rpcport 8545 --rpccorsdomain "*"

This command will allow you to communicate to the outer world using your machines IP address.

| improve this answer | |
0

Solved the issue. Instead of go through ipconfig I use docker inspect to find right ip address. With help of telnet tip address with port were verified.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.