5

I am trying to use the trace functionality included in the parity node (https://github.com/paritytech/parity/wiki/JSONRPC-trace-module) but I am having trouble configuring my node.

I have tried to run my parity node using

parity --tracing on --pruning archive

But I get the following issue:

TraceDB resync required

I have tried to reset my database by doing parity db kill and rerunning the first command but I get the same issue. Can anyone help me set up the TraceDB?

I am running parity through home-brew, version v1.8.2-beta

8

This is a minor annoyance, parity db kill does not reset your user defaults. Have a look at this:

 $ cat ~/.local/share/io.parity.ethereum/chains/ethereum/user_defaults 
 {"fat_db":false,"is_first_launch":false,"mode":"active","pruning":"fast","tracing":false}

Editing this file to read "tracing":true will solve your issue.

| improve this answer | |
1

I found a sort of solution, if you specify the db location (using --base-path) then it works. I think the parity db kill is not deleting an existing database of mine that I cannot find

| improve this answer | |
0

I have gotten past this particular issue by removing the chain and re-sync'ing.

In my case, when I start up parity, I see:

2018-08-18 06:56:57  Starting Parity-Ethereum/v2.1.0-nightly-a6ce0fe57-20180818/x86_64-linux-gnu/rustc1.28.0
2018-08-18 06:56:57  Keys path /home/[user]/.local/share/io.parity.ethereum/keys/[chain]
2018-08-18 06:56:57  DB path /home/[user]/.local/share/io.parity.ethereum/chains/[chain]/db/471758401ece60a9

To get past the problem, I deleted all traces and started over again:

rm -rf /home/[user]/.local/share/io.parity.ethereum/keys/[chain]
rm -rf /home/[user]/.local/share/io.parity.ethereum/chains/[chain]

I don't think you need to remove the keys -- simply removing the chain db should be enough:

rm -rf /home/[user]/.local/share/io.parity.ethereum/chains/[chain]/db

Obviously, you'll have to edit that to point to the parity chain db in your on environment. It may be as simple as replacing [user] with the user that runs parity and [chain] with the chain. It might not be located within your user account at all.

| improve this answer | |
0

If you are on a testing blockchain you can just delete the cache and chains folder. Editing the file user_defaults to read "tracing":true did not solve the issue for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.