2

I am following this great tutorial from Ed Zynda. I started testrpc and tried to deploy the FuncToken.sol to a Web3 Provider. I managed to connect to the local RPC (have to change protocol from https to http: in order to do it though).

And it prompted me with the error message as follows:

creation of browser/BasicToken.sol:BasicToken pending...
creation of browser/BasicToken.sol:BasicToken errored: Error: base fee exceeds gas limit
    at runCall (/usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:70875:17)
    at /usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:12643:24
    at replenish (/usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:9736:17)
    at iterateeCallback (/usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:9721:17)
    at /usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:9696:16
    at /usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:12648:13
    at /usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:67073:16
    at replenish (/usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:67020:25)
    at /usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:67029:9
    at eachLimit (/usr/local/lib/node_modules/ethereumjs-testrpc/build/cli.node.js:66953:36)

I double checked the account that I was using to deploy, it is within the local test network with a balance of 100 ethers left. I verified it both in Metamask and Remix.

At the same time, I can deploy it successfully both in Javascript VM or Injected Web3. Metamask will ask me verify the fee and submit it, however, when in the Web3 Provider mode, it just errored out without any Metamask popup.

enter image description here

Can you help me understand what I did wrong? At the same time, what does base fee and gas limit mean in this case (I manually changed the Gas Limit to be 3e12 from 3e6 and it did not help)?

  • Which version of testrpc do you use ? I had the same error message with testrpc 6.0.2. I had to downgrade to 4.1.3 : npm install -g ethereumjs-testrpc@4.1.3 – Pl4ym0re Nov 14 '17 at 21:11
  • I am having this issue when trying to test my selfDestruct function. It does not matter what values I insert, be it in MetaMask, myEtherWallet or the truffle config. In my case I am using Ganache-cli – Phillip Gibb May 6 '18 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.